Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Linux system security checks" |
| 2 | DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used." |
| 3 | SECTION = "security" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | HOMEPAGE="https://github.com/slimm609/checksec.sh" |
| 6 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=879b2147c754bc040c29e9c3b84da836" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 9 | SRCREV = "2753ebb89fcdc96433ae8a4c4e5a49214a845be2" |
| 10 | SRC_URI = "git://github.com/slimm609/checksec.sh;branch=main;protocol=https" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 ${S}/checksec ${D}${bindir} |
| 17 | } |
| 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | RDEPENDS:${PN} = "bash openssl-bin binutils" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 20 | |
| 21 | BBCLASSEXTEND = "native" |