blob: ae4c31e994d97015fae66f38973c2c0e4afe8299 [file] [log] [blame]
Jason M. Bills267243e2018-10-05 09:17:31 -07001SUMMARY = "Intel OEM IPMI commands"
2DESCRIPTION = "Intel OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
6
7SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
Andrew Geisslerd73b4042019-12-05 01:10:27 +00008SRCREV = "09a8314bb754dccd4af2ef8d2d9e6e43f6da74ec"
Jason M. Bills267243e2018-10-05 09:17:31 -07009
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
Zhikui Rencffd1212019-12-06 15:20:19 -080013DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd intel-dbus-interfaces libgpiod"
Jason M. Bills267243e2018-10-05 09:17:31 -070014
15inherit cmake obmc-phosphor-ipmiprovider-symlink
16
17EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
18
Richard Marian Thomaiyarf696ab12018-11-14 23:35:09 +053019LIBRARY_NAMES = "libzinteloemcmds.so"
Jason M. Bills267243e2018-10-05 09:17:31 -070020
21HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
23
24FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
26FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
27FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
Richard Marian Thomaiyar40ce4062018-11-21 19:21:07 +053028
29do_install_append(){
30 install -d ${D}${includedir}/intel-ipmi-oem
31 install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
Richard Marian Thomaiyarf696ab12018-11-14 23:35:09 +053032}