blob: ea0264cb3bc0f596d455b42e499ceb71756d550e [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC python devtools"
2DESCRIPTION = "Shortcut scripts for developers."
3PR = "r1"
Patrick Venture939c1202018-10-09 19:45:26 -07004PV = "1.0+git${SRCPV}"
Brad Bishop5f9be072016-06-27 14:53:52 -04005
6inherit skeleton-python
7
8VIRTUAL-RUNTIME_skeleton_workbook ?= ""
9
10RDEPENDS_${PN} += "\
11 python-dbus \
12 python-json \
13 python-xml \
14 python-pygobject \
15 ${VIRTUAL-RUNTIME_skeleton_workbook} \
16 "
17
18SKELETON_DIR = "pytools"
Andrew Jeffery7dc2acb2018-02-26 11:25:27 +103019
20do_install_append() {
21 if [ -f ${S}/obmcutil-completion.sh ]
22 then
Brad Bishop48ac60b2018-03-01 16:21:40 -050023 install -d ${D}${sysconfdir}/profile.d
24 install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
Andrew Jeffery7dc2acb2018-02-26 11:25:27 +103025 fi
26}