blob: 576185adec58cf675ab16705baeaa5d65b60cbef [file] [log] [blame]
Brad Bishopce718f92017-01-12 22:12:01 -05001SUMMARY = "Phosphor Inventory Manager"
2DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
3lifecycle management application, suitable for use on a wide variety \
4of OpenBMC platforms."
5PR = "r1"
Patrick Ventured149d4a2018-10-17 07:48:17 -07006PV = "1.0+git${SRCPV}"
Brad Bishopce718f92017-01-12 22:12:01 -05007
8inherit autotools \
9 pkgconfig \
10 pythonnative \
Marri Devender Raoc84d4132017-06-08 23:53:04 -050011 phosphor-dbus-yaml \
Brad Bishopb7d3a492017-01-28 15:28:17 -050012 phosphor-inventory-manager \
Brad Bishopce718f92017-01-12 22:12:01 -050013 obmc-phosphor-dbus-service
14
15require phosphor-inventory-manager.inc
16
17DEPENDS += " \
18 ${PN}-config-native \
Brad Bishop286df172017-02-13 22:51:36 -050019 phosphor-dbus-interfaces \
Brad Bishop15947ed2017-02-15 14:11:50 -050020 phosphor-dbus-interfaces-native \
21 phosphor-logging \
Brad Bishopce718f92017-01-12 22:12:01 -050022 sdbusplus \
23 sdbusplus-native \
24 autoconf-archive-native \
Deepak Kodihalli1d019ab2017-08-09 06:37:08 -050025 cereal \
Brad Bishopce718f92017-01-12 22:12:01 -050026 "
Brad Bishop15947ed2017-02-15 14:11:50 -050027RDEPENDS_${PN} += " \
28 sdbusplus \
29 phosphor-dbus-interfaces \
30 phosphor-logging \
31 "
Brad Bishopce718f92017-01-12 22:12:01 -050032
Brad Bishop296b27c2017-02-23 10:44:48 -050033OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
Brad Bishopce718f92017-01-12 22:12:01 -050034OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
35
36DBUS_SERVICE_${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
37
38S = "${WORKDIR}/git"
39
40EXTRA_OECONF = " \
Brad Bishopb7d3a492017-01-28 15:28:17 -050041 YAML_PATH=${STAGING_DIR_NATIVE}${base_datadir} \
Brad Bishopce718f92017-01-12 22:12:01 -050042 BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
43 INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
44 IFACE=${OBMC_INVENTORY_MGR_IFACE} \
Brad Bishop15947ed2017-02-15 14:11:50 -050045 IFACES_PATH=${STAGING_DIR_NATIVE}${yaml_dir} \
Brad Bishopce718f92017-01-12 22:12:01 -050046 "