blob: 49c0fd11e62da1273706aad942cbca0c9211dfdc [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06009SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db"
10SRC_URI = "git://github.com/smuellerDD/libkcapi.git \
11 file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
12 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14inherit autotools
15
16PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040017PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050019PACKAGECONFIG[hasher_only] = "--enable-kcapi-hasher --disable-lib-kdf --disable-lib-sym --disable-lib-aead --disable-lib-rng,,,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Patrick Williams213cb262021-08-07 19:21:33 -050021do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 # bindir contains testapp and apps. However it is always created, even
23 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
24 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040025
26 # Remove the generated binary checksum files
27 rm -f ${D}${bindir}/.*.hmac
28 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031CPPFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050032
33BBCLASSEXTEND = "native"