blob: 198f7e87c77c931480ef124316b791ed25bc6c43 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
10 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050011SRC_URI[sha256sum] = "1cefe4a3057c1522b146e62f61b80ce6e2e99da2d85ebe25bc03fc45228e58cd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13DEPENDS = "coreutils-native"
14
15PROVIDES = "stress"
Patrick Williams213cb262021-08-07 19:21:33 -050016RPROVIDES:${PN} = "stress"
17RREPLACES:${PN} = "stress"
18RCONFLICTS:${PN} = "stress"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20inherit bash-completion
21
22do_install() {
23 oe_runmake DESTDIR=${D} install
Andrew Geissler635e0e42020-08-21 15:58:33 -050024 ln -s stress-ng ${D}${bindir}/stress
Andrew Geissler82c905d2020-04-13 13:39:40 -050025}