blob: 1d43d2228ac50c7991ac6fa255ebd93ead74ce46 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD-2-Clause"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9BBCLASSEXTEND = "native nativesdk"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
12
13SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
14 file://run-ptest \
15 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
16 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
17 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050018 file://check-funcs.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060019 file://0001-Emit-no-line-directives-if-gen_line_dirs-is-false.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 "
21
22SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
23SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
24
25# Flex has moved to github from 2.6.1 onwards
26UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
27UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
28
29inherit autotools gettext texinfo ptest
30
31M4 = "${bindir}/m4"
32M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
33EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
34EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
35
36EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
37
38do_install_append_class-native() {
39 create_wrapper ${D}/${bindir}/flex M4=${M4}
40}
41
42do_install_append_class-nativesdk() {
43 create_wrapper ${D}/${bindir}/flex M4=${M4}
44}
45
46PACKAGES =+ "${PN}-libfl"
47
48FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
49
50RDEPENDS_${PN} += "m4"
51RDEPENDS_${PN}-ptest += "bash gawk make"
52
53do_compile_ptest() {
54 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
55}
56
57do_install_ptest() {
58 mkdir -p ${D}${PTEST_PATH}/build-aux/
59 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
60 cp -r ${S}/tests/* ${D}${PTEST_PATH}
61 cp -r ${B}/tests/* ${D}${PTEST_PATH}
62 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
63 -e 's|${DEBUG_PREFIX_MAP}||g' \
64 -e 's:${HOSTTOOLS_DIR}/::g' \
65 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
66 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
67 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
68 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
69 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
70 -i ${D}${PTEST_PATH}/Makefile
71}
72# The uninative loader is different on i386 & x86_64 hosts. Since it is only
73# being replaced with /bin/false anyway, it doesn't need to be part of the task
74# hash
75do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
76
77# Not Apache Flex, or Adobe Flex, or IBM Flex.
78CVE_PRODUCT = "flex_project:flex"