blob: 97e5e575331ca44e0f67e7ad6db896e94bf3364a [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Patrick Williamsc0f7c042017-02-23 20:41:17 -06005LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008PR = "r2"
9
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010S = "${WORKDIR}/zip30"
11
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
Brad Bishop15ae2502019-06-18 21:44:24 -040013 file://fix-security-format.patch \
14 file://10-remove-build-date.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://zipnote-crashes-with-segfault.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040016 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
20SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022# Disputed and also Debian doesn't consider a vulnerability
23CVE_CHECK_WHITELIST += "CVE-2018-13410"
24
25# Not for zip but for smart contract implementation for it
26CVE_CHECK_WHITELIST += "CVE-2018-13684"
27
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028# zip.inc sets CFLAGS, but what Makefile actually uses is
29# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
30# whatever we set.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
32 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
33 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
34 'INSTALL=install' 'INSTALL_D=install -d' \
35 'BINFLAGS=0755'"
36
37do_compile() {
38 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
39 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
40 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
41}
42
43do_install() {
44 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
45 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
46 install
47}
48
49BBCLASSEXTEND = "native"
50
51# exclude version 2.3.2 which triggers a false positive
52UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"