blob: 9fd512031554dcb0202557f17b965a9bb6df0542 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
Patrick Williams6d7f40b2017-08-28 12:00:05 -050012inherit pythonnative
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050013
14DEPENDS += " \
15 autoconf-archive-native \
16 phosphor-dbus-interfaces \
17 phosphor-logging \
18 sdbusplus \
Patrick Williams6d7f40b2017-08-28 12:00:05 -050019 sdbusplus-native \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050020 "
21
22RDEPENDS_${PN} += " \
23 mtd-utils-ubifs \
24 phosphor-dbus-interfaces \
25 phosphor-logging \
26 sdbusplus \
Patrick Williams21d65692017-08-09 17:36:04 -050027 virtual-obmc-image-manager \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050028 "
29
Adriana Kobylak2e950822017-06-02 09:22:40 -050030S = "${WORKDIR}/git"
31
32SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
33
Adriana Kobylake2538382017-07-06 10:31:59 -050034SRC_URI += "file://obmc-flash-bios"
Adriana Kobylak69d3de02017-05-25 15:48:27 -050035
Andrew Geisslerd2768932018-03-02 16:00:06 +000036SRCREV = "70dcb63a8c749f2a1d61621f75858085df05abcf"
Adriana Kobylak2e950822017-06-02 09:22:40 -050037
38do_install_append() {
Adriana Kobylak69d3de02017-05-25 15:48:27 -050039 install -d ${D}${sbindir}
Adriana Kobylake2538382017-07-06 10:31:59 -050040 install -m 0755 ${WORKDIR}/obmc-flash-bios ${D}${sbindir}/obmc-flash-bios
Adriana Kobylak69d3de02017-05-25 15:48:27 -050041}
42
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050043DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
Adriana Kobylak2e950822017-06-02 09:22:40 -050044
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050045SYSTEMD_SERVICE_${PN} += " \
46 obmc-flash-bios-ubiattach.service \
47 obmc-flash-bios-ubimount@.service \
Saqib Khan6316a542017-07-29 11:27:27 -050048 obmc-flash-bios-ubiumount-ro@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050049 obmc-flash-bios-ubiumount-rw@.service \
Adriana Kobylakd8b85752017-07-12 13:52:22 -050050 obmc-flash-bios-ubipatch.service \
Saqib Khanbea768c2017-07-26 23:48:20 -050051 obmc-flash-bios-ubiremount.service \
Saqib Khanfa92e972017-08-02 12:48:12 -050052 obmc-flash-bios-updatesymlinks.service \
Michael Tritzf15008a2017-09-22 15:00:51 -050053 obmc-flash-bios-ubiclear@.service \
Michael Tritzed6d7b02017-09-21 00:41:15 -050054 obmc-flash-bios-cleanup.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050055 "