blob: 25544029d5c1ded30b32a7b9aa60511d8b7a35a5 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "Boot performance graphing tool"
2DESCRIPTION = "For systemd-bootchart, several proc debug interfaces are required in the kernel config: \
3 CONFIG_SCHEDSTATS \
4below is optional, for additional info: \
5 CONFIG_SCHED_DEBUG"
6HOMEPAGE = "https://github.com/systemd/systemd-bootchart"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.1-only & GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
9 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
10
Patrick Williams705982a2024-01-12 09:51:57 -060011SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https;branch=main \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 file://mips64.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060013 file://no_lto.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040014"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016SRC_URI:append:libc-musl = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -040017 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
18 file://0002-musl-does-not-provide-printf-h.patch \
19 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
20 "
21
22
Patrick Williams705982a2024-01-12 09:51:57 -060023SRCREV = "8ab9680a1bd5eb8fe7a7dcc44897af7ee41e56e7"
Brad Bishop316dfdd2018-06-25 12:45:53 -040024
25S = "${WORKDIR}/git"
26
27DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
28
Brad Bishop6dbb3162019-11-25 09:41:34 -050029inherit pkgconfig autotools systemd features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040030
31REQUIRED_DISTRO_FEATURES = "systemd"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033SYSTEMD_SERVICE:${PN} = "systemd-bootchart.service"
Brad Bishop316dfdd2018-06-25 12:45:53 -040034
Patrick Williams213cb262021-08-07 19:21:33 -050035do_configure:prepend() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040036 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
37 rm -f ${S}/m4/intltool.m4
38}
39
Andrew Geissler595f6302022-01-24 19:11:47 +000040FILES:${PN} += "${systemd_unitdir}/systemd-bootchart"
Brad Bishop316dfdd2018-06-25 12:45:53 -040041
Brad Bishop79641f22019-09-10 07:20:22 -040042EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040043 --with-rootlibdir=${base_libdir}"