blob: c9e5617e7eb51acc0f71c773e3550eefebb1c85f [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
4SECTION = "x11/office"
5DEPENDS = " \
6 gnome-common-native \
7 yelp-tools-native \
8 appstream-glib \
9 gtk+3 \
10 gspell \
11 libsecret \
12 poppler \
13 gstreamer1.0-plugins-base \
14 orc \
15 adwaita-icon-theme \
16 libhandy \
Andrew Geisslerd5838332022-05-27 11:33:10 -050017 ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop','dbus',d)} \
Andrew Geissler9aee5002022-03-30 16:27:02 +000018"
19
20GNOMEBASEBUILDCLASS = "meson"
21
22inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection gettext mime-xdg gtk-doc
23
24def gnome_verdir(v):
25 return oe.utils.trim_version(v, 1)
26
Patrick Williams03907ee2022-05-01 06:28:52 -050027SRC_URI[archive.sha256sum] = "ff7f81f308cf8d4956ed97fb724a7e49448c214beeab998812ef9efbb38df8ae"
Andrew Geissler9aee5002022-03-30 16:27:02 +000028
29GTKDOC_MESON_OPTION = "gtk_doc"
30
31EXTRA_OEMESON = " \
32 -Dsystemduserunitdir=no \
33"
34
35do_compile:prepend() {
36 export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs"
37}
38
39PACKAGECONFIG ??= ""
40PACKAGECONFIG[nautilus] = "-Dnautilus=true,-Dnautilus=false,nautilus"
41
42RDEPENDS:${PN} += "glib-2.0-utils"
43RRECOMMMENDS_${PN} = "adwaita-icon-theme"
44
45PACKAGES =+ "${PN}-nautilus-extension"
46
47FILES:${PN} += "${datadir}/dbus-1 \
48 ${datadir}/metainfo \
49 ${datadir}/thumbnailers \
50"
51FILES:${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"