blob: 3483db3c8348f36e8259d78a24ef79913eeb94c1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# TODO: include debian's mtp-tools man page (needs xsltproc-native and
2# docbook-xsl-native, or we pregenerate it), add support for doxygen
3# generation fully with -natives
4DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \
5Protocol (MTP) in the form of a library suitable primarily for POSIX \
6compliant operating systems"
7SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)"
8HOMEPAGE = "http://libmtp.sourceforge.net/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-or-later"
Patrick Williams03907ee2022-05-01 06:28:52 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \
11 file://src/ptp.c;beginline=3;endline=22;md5=80fd2d5904c4c1f5455d8f4bf515292f \
12 file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \
13 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15BBCLASSEXTEND = "native"
16
17DEPENDS = "libusb1 gettext-native"
Patrick Williams213cb262021-08-07 19:21:33 -050018DEPENDS:append:class-target = " ${BPN}-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
Patrick Williams213cb262021-08-07 19:21:33 -050021SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
Patrick Williams03907ee2022-05-01 06:28:52 -050023SRC_URI[sha256sum] = "deb4af6f63f5e71215cfa7fb961795262920b4ec6cb4b627f55b30b18aa33228"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25inherit autotools pkgconfig lib_package
26
27EXTRA_OECONF += " \
28 --disable-rpath \
29 --with-udev=${nonarch_base_libdir}/udev \
30"
31
32PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}"
Andrew Geisslerd5838332022-05-27 11:33:10 -050033PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen,doxygen-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile"
35PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt"
36
37PACKAGES =+ "${BPN}-common ${BPN}-runtime"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${BPN} += "libmtp-common"
40RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin"
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*"
43SUMMARY:${BPN}-common = "The udev rules file for MTP devices"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe"
46RDEPENDS:${BPN}-runtime = "libmtp-common"
47SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules"
48DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules."