blob: 9feb26770ab39a9095f02e2373f1fc8d4db33a15 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2013 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
5
6# testimage.bbclass enables testing of qemu images using python unittests.
7# Most of the tests are commands run on target image over ssh.
8# To use it add testimage to global inherit and call your target image with -c testimage
9# You can try it out like this:
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010# - first add IMAGE_CLASSES += "testimage" in local.conf
11# - build a qemu core-image-sato
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012# - then bitbake core-image-sato -c testimage. That will run a standard suite of tests.
13
14# You can set (or append to) TEST_SUITES in local.conf to select the tests
15# which you want to run for your target.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016# The test names are the module names in meta/lib/oeqa/runtime/cases.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# Each name in TEST_SUITES represents a required test for the image. (no skipping allowed)
18# Appending "auto" means that it will try to run all tests that are suitable for the image (each test decides that on it's own).
19# Note that order in TEST_SUITES is relevant: tests are run in an order such that
20# tests mentioned in @skipUnlessPassed run before the tests that depend on them,
21# but without such dependencies, tests run in the order in which they are listed
22# in TEST_SUITES.
23#
24# A layer can add its own tests in lib/oeqa/runtime, provided it extends BBPATH as normal in its layer.conf.
25
26# TEST_LOG_DIR contains a command ssh log and may contain infromation about what command is running, output and return codes and for qemu a boot log till login.
27# Booting is handled by this class, and it's not a test in itself.
28# TEST_QEMUBOOT_TIMEOUT can be used to set the maximum time in seconds the launch code will wait for the login prompt.
29
30TEST_LOG_DIR ?= "${WORKDIR}/testimage"
31
32TEST_EXPORT_DIR ?= "${TMPDIR}/testimage/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033TEST_INSTALL_TMP_DIR ?= "${WORKDIR}/testimage/install_tmp"
34TEST_NEEDED_PACKAGES_DIR ?= "${WORKDIR}/testimage/packages"
35TEST_EXTRACTED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/extracted"
36TEST_PACKAGED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/packaged"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038RPMTESTSUITE = "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf rpm', '', d)}"
39SYSTEMDSUITE = "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050040MINTESTSUITE = "ping"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041NETTESTSUITE = "${MINTESTSUITE} ssh df date scp oe_syslog ${SYSTEMDSUITE}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050042DEVTESTSUITE = "gcc kernelmodule ldd"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050044DEFAULT_TEST_SUITES = "${MINTESTSUITE} auto"
45DEFAULT_TEST_SUITES_pn-core-image-minimal = "${MINTESTSUITE}"
46DEFAULT_TEST_SUITES_pn-core-image-minimal-dev = "${MINTESTSUITE}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040047DEFAULT_TEST_SUITES_pn-core-image-full-cmdline = "${NETTESTSUITE} perl python logrotate ptest"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050048DEFAULT_TEST_SUITES_pn-core-image-x11 = "${MINTESTSUITE}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040049DEFAULT_TEST_SUITES_pn-core-image-lsb = "${NETTESTSUITE} pam parselogs ${RPMTESTSUITE} ptest"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050DEFAULT_TEST_SUITES_pn-core-image-sato = "${NETTESTSUITE} connman xorg parselogs ${RPMTESTSUITE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040051 ${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'python', '', d)} ptest gi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050052DEFAULT_TEST_SUITES_pn-core-image-sato-sdk = "${NETTESTSUITE} buildcpio buildlzip buildgalculator \
Brad Bishop316dfdd2018-06-25 12:45:53 -040053 connman ${DEVTESTSUITE} logrotate perl parselogs python ${RPMTESTSUITE} xorg ptest gi stap"
54DEFAULT_TEST_SUITES_pn-core-image-lsb-dev = "${NETTESTSUITE} pam perl python parselogs ${RPMTESTSUITE} ptest gi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055DEFAULT_TEST_SUITES_pn-core-image-lsb-sdk = "${NETTESTSUITE} buildcpio buildlzip buildgalculator \
Brad Bishop316dfdd2018-06-25 12:45:53 -040056 connman ${DEVTESTSUITE} logrotate pam parselogs perl python ${RPMTESTSUITE} ptest gi stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057DEFAULT_TEST_SUITES_pn-meta-toolchain = "auto"
58
59# aarch64 has no graphics
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050060DEFAULT_TEST_SUITES_remove_aarch64 = "xorg"
Brad Bishop316dfdd2018-06-25 12:45:53 -040061# musl doesn't support systemtap
62DEFAULT_TEST_SUITES_remove_libc-musl = "stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064# qemumips is quite slow and has reached the timeout limit several times on the YP build cluster,
65# mitigate this by removing build tests for qemumips machines.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066MIPSREMOVE ??= "buildcpio buildlzip buildgalculator"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060067DEFAULT_TEST_SUITES_remove_qemumips = "${MIPSREMOVE}"
68DEFAULT_TEST_SUITES_remove_qemumips64 = "${MIPSREMOVE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069
70TEST_SUITES ?= "${DEFAULT_TEST_SUITES}"
71
72TEST_QEMUBOOT_TIMEOUT ?= "1000"
73TEST_TARGET ?= "qemu"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074
75TESTIMAGEDEPENDS = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050076TESTIMAGEDEPENDS_qemuall = "qemu-native:do_populate_sysroot qemu-helper-native:do_populate_sysroot qemu-helper-native:do_addto_recipe_sysroot"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
78TESTIMAGEDEPENDS_qemuall += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050079TESTIMAGEDEPENDS_qemuall += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
80TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf-native:do_populate_sysroot', '', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060081TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'ipk', 'opkg-utils-native:do_populate_sysroot', '', d)}"
82TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'deb', 'apt-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050083TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084
85TESTIMAGELOCK = "${TMPDIR}/testimage.lock"
86TESTIMAGELOCK_qemuall = ""
87
88TESTIMAGE_DUMP_DIR ?= "/tmp/oe-saved-tests/"
89
Brad Bishop6e60e8b2018-02-01 10:27:11 -050090TESTIMAGE_UPDATE_VARS ?= "DL_DIR WORKDIR DEPLOY_DIR"
91
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092testimage_dump_target () {
93 top -bn1
94 ps
95 free
96 df
97 # The next command will export the default gateway IP
98 export DEFAULT_GATEWAY=$(ip route | awk '/default/ { print $3}')
99 ping -c3 $DEFAULT_GATEWAY
100 dmesg
101 netstat -an
102 ip address
103 # Next command will dump logs from /var/log/
104 find /var/log/ -type f 2>/dev/null -exec echo "====================" \; -exec echo {} \; -exec echo "====================" \; -exec cat {} \; -exec echo "" \;
105}
106
107testimage_dump_host () {
108 top -bn1
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500109 iostat -x -z -N -d -p ALL 20 2
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500110 ps -ef
111 free
112 df
113 memstat
114 dmesg
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500115 ip -s link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500116 netstat -an
117}
118
119python do_testimage() {
120 testimage_main(d)
121}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600122
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123addtask testimage
124do_testimage[nostamp] = "1"
125do_testimage[depends] += "${TESTIMAGEDEPENDS}"
126do_testimage[lockfiles] += "${TESTIMAGELOCK}"
127
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500128def testimage_sanity(d):
129 if (d.getVar('TEST_TARGET') == 'simpleremote'
130 and (not d.getVar('TEST_TARGET_IP')
131 or not d.getVar('TEST_SERVER_IP'))):
132 bb.fatal('When TEST_TARGET is set to "simpleremote" '
133 'TEST_TARGET_IP and TEST_SERVER_IP are needed too.')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500135def testimage_main(d):
136 import os
137 import json
138 import signal
139 import logging
140
141 from bb.utils import export_proxies
142 from oeqa.core.utils.misc import updateTestData
143 from oeqa.runtime.context import OERuntimeTestContext
144 from oeqa.runtime.context import OERuntimeTestContextExecutor
145 from oeqa.core.target.qemu import supported_fstypes
146 from oeqa.core.utils.test import getSuiteCases
147 from oeqa.utils import make_logger_bitbake_compatible
148
149 def sigterm_exception(signum, stackframe):
150 """
151 Catch SIGTERM from worker in order to stop qemu.
152 """
153 raise RuntimeError
154
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700155 testimage_sanity(d)
156
157 if (d.getVar('IMAGE_PKGTYPE') == 'rpm'
158 and ('dnf' in d.getVar('TEST_SUITES') or 'auto' in d.getVar('TEST_SUITES'))):
159 create_rpm_index(d)
160
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500161 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
162 pn = d.getVar("PN")
163
164 bb.utils.mkdirhier(d.getVar("TEST_LOG_DIR"))
165
166 image_name = ("%s/%s" % (d.getVar('DEPLOY_DIR_IMAGE'),
167 d.getVar('IMAGE_LINK_NAME')))
168
169 tdname = "%s.testdata.json" % image_name
170 try:
171 td = json.load(open(tdname, "r"))
172 except (FileNotFoundError) as err:
173 bb.fatal('File %s Not Found. Have you built the image with INHERIT+="testimage" in the conf/local.conf?' % tdname)
174
175 # Some variables need to be updates (mostly paths) with the
176 # ones of the current environment because some tests require them.
177 updateTestData(d, td, d.getVar('TESTIMAGE_UPDATE_VARS').split())
178
179 image_manifest = "%s.manifest" % image_name
180 image_packages = OERuntimeTestContextExecutor.readPackagesManifest(image_manifest)
181
182 extract_dir = d.getVar("TEST_EXTRACTED_DIR")
183
184 # Get machine
185 machine = d.getVar("MACHINE")
186
187 # Get rootfs
188 fstypes = [fs for fs in d.getVar('IMAGE_FSTYPES').split(' ')
189 if fs in supported_fstypes]
190 if not fstypes:
191 bb.fatal('Unsupported image type built. Add a comptible image to '
192 'IMAGE_FSTYPES. Supported types: %s' %
193 ', '.join(supported_fstypes))
194 rootfs = '%s.%s' % (image_name, fstypes[0])
195
196 # Get tmpdir (not really used, just for compatibility)
197 tmpdir = d.getVar("TMPDIR")
198
199 # Get deploy_dir_image (not really used, just for compatibility)
200 dir_image = d.getVar("DEPLOY_DIR_IMAGE")
201
202 # Get bootlog
203 bootlog = os.path.join(d.getVar("TEST_LOG_DIR"),
204 'qemu_boot_log.%s' % d.getVar('DATETIME'))
205
206 # Get display
207 display = d.getVar("BB_ORIGENV").getVar("DISPLAY")
208
209 # Get kernel
210 kernel_name = ('%s-%s.bin' % (d.getVar("KERNEL_IMAGETYPE"), machine))
211 kernel = os.path.join(d.getVar("DEPLOY_DIR_IMAGE"), kernel_name)
212
213 # Get boottime
214 boottime = int(d.getVar("TEST_QEMUBOOT_TIMEOUT"))
215
216 # Get use_kvm
217 qemu_use_kvm = d.getVar("QEMU_USE_KVM")
218 if qemu_use_kvm and \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400219 (oe.types.boolean(qemu_use_kvm) and 'x86' in machine or \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500220 d.getVar('MACHINE') in qemu_use_kvm.split()):
221 kvm = True
222 else:
223 kvm = False
224
225 # TODO: We use the current implementatin of qemu runner because of
226 # time constrains, qemu runner really needs a refactor too.
227 target_kwargs = { 'machine' : machine,
228 'rootfs' : rootfs,
229 'tmpdir' : tmpdir,
230 'dir_image' : dir_image,
231 'display' : display,
232 'kernel' : kernel,
233 'boottime' : boottime,
234 'bootlog' : bootlog,
235 'kvm' : kvm,
236 }
237
238 # TODO: Currently BBPATH is needed for custom loading of targets.
239 # It would be better to find these modules using instrospection.
240 target_kwargs['target_modules_path'] = d.getVar('BBPATH')
241
242 # runtime use network for download projects for build
243 export_proxies(d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500244
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500245 # we need the host dumper in test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500246 host_dumper = OERuntimeTestContextExecutor.getHostDumper(
247 d.getVar("testimage_dump_host"),
248 d.getVar("TESTIMAGE_DUMP_DIR"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500249
250 # the robot dance
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500251 target = OERuntimeTestContextExecutor.getTarget(
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500252 d.getVar("TEST_TARGET"), logger, d.getVar("TEST_TARGET_IP"),
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500253 d.getVar("TEST_SERVER_IP"), **target_kwargs)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500254
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255 # test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500256 tc = OERuntimeTestContext(td, logger, target, host_dumper,
257 image_packages, extract_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500259 # Load tests before starting the target
260 test_paths = get_runtime_paths(d)
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500261 test_modules = d.getVar('TEST_SUITES').split()
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700262 if not test_modules:
263 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
264
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500265 tc.loadTests(test_paths, modules=test_modules)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500266
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700267 suitecases = getSuiteCases(tc.suites)
268 if not suitecases:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500269 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700270 else:
271 bb.debug(2, 'test suites:\n\t%s' % '\n\t'.join([str(c) for c in suitecases]))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500272
273 package_extraction(d, tc.suites)
274
275 bootparams = None
276 if d.getVar('VIRTUAL-RUNTIME_init_manager', '') == 'systemd':
277 # Add systemd.log_level=debug to enable systemd debug logging
278 bootparams = 'systemd.log_target=console'
279
280 results = None
281 orig_sigterm_handler = signal.signal(signal.SIGTERM, sigterm_exception)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600282 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500283 # We need to check if runqemu ends unexpectedly
284 # or if the worker send us a SIGTERM
285 tc.target.start(extra_bootparams=bootparams)
286 results = tc.runTests()
287 except (RuntimeError, BlockingIOError) as err:
288 if isinstance(err, RuntimeError):
289 bb.error('testimage received SIGTERM, shutting down...')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600290 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500291 bb.error('runqemu failed, shutting down...')
292 if results:
293 results.stop()
294 results = None
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600295 finally:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500296 signal.signal(signal.SIGTERM, orig_sigterm_handler)
297 tc.target.stop()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600298
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500299 # Show results (if we have them)
300 if not results:
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500301 bb.fatal('%s - FAILED - tests were interrupted during execution' % pn, forcelog=True)
302 results.logDetails()
303 results.logSummary(pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500304 if not results.wasSuccessful():
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500305 bb.fatal('%s - FAILED - check the task log and the ssh log' % pn, forcelog=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600306
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500307def get_runtime_paths(d):
308 """
309 Returns a list of paths where runtime test must reside.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500310
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500311 Runtime tests are expected in <LAYER_DIR>/lib/oeqa/runtime/cases/
312 """
313 paths = []
314
315 for layer in d.getVar('BBLAYERS').split():
316 path = os.path.join(layer, 'lib/oeqa/runtime/cases')
317 if os.path.isdir(path):
318 paths.append(path)
319 return paths
320
321def create_index(arg):
322 import subprocess
323
324 index_cmd = arg
325 try:
326 bb.note("Executing '%s' ..." % index_cmd)
327 result = subprocess.check_output(index_cmd,
328 stderr=subprocess.STDOUT,
329 shell=True)
330 result = result.decode('utf-8')
331 except subprocess.CalledProcessError as e:
332 return("Index creation command '%s' failed with return code "
333 '%d:\n%s' % (e.cmd, e.returncode, e.output.decode("utf-8")))
334 if result:
335 bb.note(result)
336 return None
337
338def create_rpm_index(d):
339 # Index RPMs
340 rpm_createrepo = bb.utils.which(os.getenv('PATH'), "createrepo_c")
341 index_cmds = []
342 archs = (d.getVar('ALL_MULTILIB_PACKAGE_ARCHS') or '').replace('-', '_')
343
344 for arch in archs.split():
345 rpm_dir = os.path.join(d.getVar('DEPLOY_DIR_RPM'), arch)
346 idx_path = os.path.join(d.getVar('WORKDIR'), 'oe-testimage-repo', arch)
347
348 if not os.path.isdir(rpm_dir):
349 continue
350
351 lockfilename = os.path.join(d.getVar('DEPLOY_DIR_RPM'), 'rpm.lock')
352 lf = bb.utils.lockfile(lockfilename, False)
353 oe.path.copyhardlinktree(rpm_dir, idx_path)
354 # Full indexes overload a 256MB image so reduce the number of rpms
355 # in the feed. Filter to r* since we use the run-postinst packages and
356 # this leaves some allarch and machine arch packages too.
357 bb.utils.remove(idx_path + "*/[a-qs-z]*.rpm")
358 bb.utils.unlockfile(lf)
359 cmd = '%s --update -q %s' % (rpm_createrepo, idx_path)
360
361 # Create repodata
362 result = create_index(cmd)
363 if result:
364 bb.fatal('%s' % ('\n'.join(result)))
365
366def package_extraction(d, test_suites):
367 from oeqa.utils.package_manager import find_packages_to_extract
368 from oeqa.utils.package_manager import extract_packages
369
370 bb.utils.remove(d.getVar("TEST_NEEDED_PACKAGES_DIR"), recurse=True)
371 packages = find_packages_to_extract(test_suites)
372 if packages:
373 bb.utils.mkdirhier(d.getVar("TEST_INSTALL_TMP_DIR"))
374 bb.utils.mkdirhier(d.getVar("TEST_PACKAGED_DIR"))
375 bb.utils.mkdirhier(d.getVar("TEST_EXTRACTED_DIR"))
376 extract_packages(d, packages)
377
378testimage_main[vardepsexclude] += "BB_ORIGENV DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500379
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500380inherit testsdk