blob: 5505626d3e0b7b871c20507d8487bc97dffaa85f [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LICENSE = "GPL-2.0+ & LGPL-2.1+"
Brad Bishope42b3e32020-01-15 22:08:42 -05005
6LIC_FILES_CHKSUM = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007 file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
8 file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -05009"
10
11SRC_URI = " \
12 git://linuxtv.org/libcamera.git;protocol=git \
Brad Bishope42b3e32020-01-15 22:08:42 -050013"
14
Andrew Geisslerd688a012020-09-18 13:36:00 -050015SRCREV = "1e8c91b65695449c5246d17ba7dc439c8058b781"
Brad Bishope42b3e32020-01-15 22:08:42 -050016
Andrew Geisslerd688a012020-09-18 13:36:00 -050017PV = "202008+git${SRCPV}"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19S = "${WORKDIR}/git"
20
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native"
Brad Bishope42b3e32020-01-15 22:08:42 -050022DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
23
Andrew Geisslerd688a012020-09-18 13:36:00 -050024PACKAGES =+ "${PN}-gst"
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
28
Brad Bishope42b3e32020-01-15 22:08:42 -050029RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
30
31inherit meson pkgconfig python3native
32
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050033do_install_append() {
34 chrpath -d ${D}${libdir}/libcamera.so
35}
36
37addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata
38do_recalculate_ipa_signatures_package() {
39 local modules
40 for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
41 module="${module%.sign}"
42 if [ -f "${module}" ] ; then
43 modules="${modules} ${module}"
44 fi
45 done
46
47 ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
48}
49
Brad Bishope42b3e32020-01-15 22:08:42 -050050FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
51FILES_${PN} += " ${libdir}/libcamera.so"
Andrew Geisslerd688a012020-09-18 13:36:00 -050052FILES_${PN}-gst = "${libdir}/gstreamer-1.0/libgstlibcamera.so"