blob: bd55efce27abd4c54fc4e7883d3b87622bac7981 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "VLAN provides vconfig utility"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://www.candelatech.com/~greear/vlan.html"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003SECTION = "misc"
4LICENSE = "GPLv2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
7SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008 file://no-HOME-includes.patch \
9 file://0001-Add-printf-format-and-silence-format-security-warnin.patch \
10"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
13SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
14
15S = "${WORKDIR}/${BPN}"
16
17EXTRA_OEMAKE = "-e MAKEFLAGS="
18
19# comment out MakeInclude in Makefile which sets build environment
20do_configure_append () {
21 sed -i 's/^ include/#^include/' ${S}/Makefile
22}
23
24# ignore strip to avoid yocto errors in stripping
25do_compile () {
26 oe_runmake PLATFORM=ARM 'STRIP=echo' all
27}
28
29do_install () {
30 install -d ${D}/${base_sbindir}
31 install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
32}