blob: 87a23af19f1cec26ca7309de45dd2c7d791d4de2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008PV = "17.03.00+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010SRCREV = "0153ea51cb648b3067a1b327eee6a075b6cfa330"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
14 file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
15 file://0003-Undefine-PAGE_SIZE.patch \
16 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
17 file://0002-Add-C99-defined-format-for-printing-uint64_t.patch \
18 file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21S = "${WORKDIR}/git"
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025DEPENDS = "libpcre json-c glib-2.0 dtc"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028inherit autotools pkgconfig
29
30CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031LDFLAGS_append_libc-musl = " -lexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032
33FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
34FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
35FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
36FILES_${PN}-dbg += "${libdir}/fwts/.debug"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037
38TOOLCHAIN = "gcc"
39