blob: ab2fcd7abc0e8ace0d576ec0569a1657bbb583be [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
8SRCREV = "b9a735e9c7cf82f80d412b7ab15d08b89d5a4ccc"
9PV = "1.3.0+git${SRCPV}"
10
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git;branch=1.3_mars_bugfix \
13 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://ldflags.patch \
15 file://0001-canonicalize_file_name-is-specific-to-glibc.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016 file://tcf-agent.init \
17 file://tcf-agent.service \
18 "
19
20DEPENDS = "util-linux openssl"
21RDEPENDS_${PN} = "bash"
22
23S = "${WORKDIR}/git/agent"
24
25inherit update-rc.d systemd
26
27SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
28
29INITSCRIPT_NAME = "tcf-agent"
30INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
31
32# mangling needed for make
33MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
34MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
35
36EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
37
38# They don't build on ARM and we don't need them actually.
39CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
40 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
41 -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
42 -DSERVICE_Expressions=0"
43
44do_install() {
45 oe_runmake install INSTALLROOT=${D}
46 install -d ${D}${sysconfdir}/init.d/
47 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
48 install -d ${D}${systemd_unitdir}/system
49 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
50 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
51}
52