blob: 653541e3c8bb4b9aa664680db9ae2805b8983158 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05005SRC_URI = "file://init \
6 file://weston.service"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8S = "${WORKDIR}"
9
10do_install() {
11 install -d ${D}/${sysconfdir}/init.d
12 install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013
14 install -d ${D}${systemd_system_unitdir}
15 install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016}
17
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018inherit allarch update-rc.d distro_features_check systemd
19
20# rdepends on weston which depends on virtual/egl
21REQUIRED_DISTRO_FEATURES = "opengl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23RDEPENDS_${PN} = "weston kbd"
24
25INITSCRIPT_NAME = "weston"
26INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050027
28SYSTEMD_SERVICE_${PN} = "weston.service"