blob: a59a5c41dff2cd4cea3a10316ecddf86db2ba78c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A shared storage lock manager"
2DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
3to the storage can perform locking. An application running on the \
4hosts is given a small amount of space on the shared block device or \
5file, and uses sanlock for its own application-specific synchronization. \
6Internally, the sanlock daemon manages locks using two disk-based \
7lease algorithms: delta leases and paxos leases."
8HOMEPAGE = "https://pagure.io/sanlock"
9SECTION = "utils"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "LGPL-2.0-or-later & GPL-2.0-only & GPL-2.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +000012LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
Brad Bishope42b3e32020-01-15 22:08:42 -050013
14PV .= "+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://pagure.io/sanlock.git;protocol=http;branch=master \
17 file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \
18 file://setuptools.patch \
Brad Bishop8410d612019-11-25 09:40:59 -050019 "
Patrick Williams93c203f2021-10-06 16:15:23 -050020SRCREV = "a181e951376d49a82eef17920c8ebedec80b4823"
Brad Bishope42b3e32020-01-15 22:08:42 -050021
Andrew Geissler595f6302022-01-24 19:11:47 +000022S = "${WORKDIR}/git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050024CVE_CHECK_IGNORE += "\
25 CVE-2012-5638 \
26"
27
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028DEPENDS = "libaio util-linux"
29
Andrew Geissler595f6302022-01-24 19:11:47 +000030inherit setuptools3 useradd
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Andrew Geissler595f6302022-01-24 19:11:47 +000032SETUPTOOLS_SETUP_PATH = "${S}/python"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
Patrick Williams213cb262021-08-07 19:21:33 -050034do_compile:prepend () {
Andrew Geissler595f6302022-01-24 19:11:47 +000035 oe_runmake -C ${S}/wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
36 oe_runmake -C ${S}/src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:prepend () {
Andrew Geissler595f6302022-01-24 19:11:47 +000040 oe_runmake -C ${S}/wdmd DESTDIR=${D} LIBDIR=${libdir} install
41 oe_runmake -C ${S}/src DESTDIR=${D} LIBDIR=${libdir} install
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042}
Brad Bishop8410d612019-11-25 09:40:59 -050043
44SANLOCKGROUP ?= "sanlock"
45SANLOCKUSER ?= "sanlock"
46USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050047GROUPADD_PARAM:${PN} = "--system ${SANLOCKGROUP}"
48USERADD_PARAM:${PN} = "--system -g ${SANLOCKGROUP} -G disk \
Brad Bishop8410d612019-11-25 09:40:59 -050049 --home-dir /run/${SANLOCKUSER} --no-create-home \
50 --shell /sbin/nologin ${SANLOCKUSER}"