blob: 3d8a45786de9ee92453e1460945d995d2cef674f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06002
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003SECTION = "x11/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop996bc452019-12-02 13:05:15 -05006DEPENDS = "python3 virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Brad Bishop996bc452019-12-02 13:05:15 -05008inherit autotools gettext pkgconfig gconf perlnative python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI = "\
11 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
12 file://sanitize-configure.ac.patch \
13 file://purple-OE-branding-25.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014"
15
Andrew Geisslere34f8962021-04-15 15:53:51 -050016SRC_URI[sha256sum] = "19654ad276b149646371fbdac21bc7620742f2975f7399fed0ffc1a18fbaf603"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050018CVE_CHECK_IGNORE += "\
19 CVE-2010-1624 \
20 CVE-2011-3594 \
21"
22
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
25"
26PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
27# --disable-gstreamer compile without GStreamer audio support
28# --disable-gstreamer-video
29# compile without GStreamer 1.0 Video Overlay support
30# --disable-gstreamer-interfaces
31# compile without GStreamer 0.10 interface support
32# --with-gstreamer=<version>
33# compile with GStreamer 0.10 or 1.0 interface
34PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
35PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
36PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
37PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
38PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
39PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060040PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,libgnt"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
42PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
43PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
44PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
Andrew Geisslere34f8962021-04-15 15:53:51 -050045PACKAGECONFIG[cyrus-sasl] = "--enable-cyrus-sasl,--disable-cyrus-sasl,cyrus-sasl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050046
47EXTRA_OECONF = " \
48 --disable-perl \
49 --disable-tcl \
50 --disable-gevolution \
51 --disable-schemas-install \
52 --disable-gtkspell \
53 --disable-meanwhile \
54 --disable-nm \
55 --disable-screensaver \
56"
57
Brad Bishopd7bf8c12018-02-25 22:55:05 -050058OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
59OE_LT_RPATH_ALLOW[export]="1"
60
Andrew Geisslerac970dd2021-02-12 15:32:45 -060061PACKAGES =+ "libpurple-dev libpurple finch finch-dev ${PN}-data"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062
Patrick Williams213cb262021-08-07 19:21:33 -050063RPROVIDES:${PN}-dbg += "libpurple-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050064
65LEAD_SONAME = "libpurple.so.0"
Patrick Williams213cb262021-08-07 19:21:33 -050066FILES:libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
67FILES:libpurple-dev = "${libdir}/libpurple*.la \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050068 ${libdir}/libpurple*.so \
69 ${libdir}/purple-2/*.la \
70 ${libdir}/purple-2/libjabber.so \
71 ${libdir}/purple-2/liboscar.so \
72 ${libdir}/purple-2/libymsg.so \
73 ${datadir}/aclocal"
Patrick Williams213cb262021-08-07 19:21:33 -050074FILES:finch = "${bindir}/finch"
75FILES:finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050076
Patrick Williams213cb262021-08-07 19:21:33 -050077FILES:${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078 ${datadir}/applications"
Patrick Williams213cb262021-08-07 19:21:33 -050079RRECOMMENDS:${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050080
Patrick Williams213cb262021-08-07 19:21:33 -050081FILES:${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
82FILES:${PN}-dev += "${libdir}/${PN}/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083
84PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
85
Patrick Williams213cb262021-08-07 19:21:33 -050086python populate_packages:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087 pidgroot = d.expand('${libdir}/pidgin')
88 purple = d.expand('${libdir}/purple-2')
89 finch = d.expand('${libdir}/finch')
90
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000091 do_split_packages(d, pidgroot, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050092 output_pattern='pidgin-plugin-%s',
93 description='Pidgin plugin %s',
94 prepend=True, extra_depends='')
95
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000096 do_split_packages(d, purple, r'^lib(.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050097 output_pattern='libpurple-protocol-%s',
98 description='Libpurple protocol plugin for %s',
99 prepend=True, extra_depends='')
100
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000101 do_split_packages(d, purple, r'^(ssl-.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500102 output_pattern='libpurple-plugin-%s',
103 description='libpurple plugin %s',
104 prepend=True, extra_depends='libpurple-plugin-ssl')
105
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000106 do_split_packages(d, purple, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500107 output_pattern='libpurple-plugin-%s',
108 description='libpurple plugin %s',
109 prepend=True, extra_depends='')
110
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000111 do_split_packages(d, finch, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500112 output_pattern='finch-plugin-%s',
113 description='Finch plugin %s',
114 prepend=True, extra_depends='')
115}