blob: 1f55267f59e04b9ff9373e22a418fcd451160c36 [file] [log] [blame]
Brad Bishopa48c0142020-01-06 09:48:41 -05001SUMMARY = "Daemon to ban hosts that cause multiple authentication errors."
2DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \
3many failed login attempts. It does this by updating system firewall rules to reject new \
4connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \
5out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \
6and is easy to configure to read any log file you choose, for any error you choose."
7HOMEPAGE = "http://www.fail2ban.org"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-only"
Brad Bishopa48c0142020-01-06 09:48:41 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f"
Brad Bishop15ae2502019-06-18 21:44:24 -040011
Patrick Williamsde0582f2022-04-08 10:23:27 -050012DEPENDS = "python3-native"
13
Patrick Williams53961c22022-01-20 11:06:23 -060014SRCREV ="4fe4ac8dde6ba14841da598ec37f8c6911fe0f64"
15SRC_URI = " git://github.com/fail2ban/fail2ban.git;branch=0.11;protocol=https \
Andrew Geissler1fe918a2020-05-15 14:16:47 -050016 file://initd \
Brad Bishopa48c0142020-01-06 09:48:41 -050017 file://run-ptest \
Brad Bishop15ae2502019-06-18 21:44:24 -040018"
Brad Bishopa48c0142020-01-06 09:48:41 -050019
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050020UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
21
Andrew Geissler9aee5002022-03-30 16:27:02 +000022inherit update-rc.d ptest setuptools3_legacy
Brad Bishopa48c0142020-01-06 09:48:41 -050023
24S = "${WORKDIR}/git"
25
Patrick Williams53961c22022-01-20 11:06:23 -060026do_compile () {
Andrew Geissler8b139282021-03-05 15:22:30 -060027 cd ${S}
Patrick Williamsde0582f2022-04-08 10:23:27 -050028
29 #remove symlink to python3
30 # otherwise 2to3 is run against it
31 rm -f bin/fail2ban-python
32
Andrew Geissler8b139282021-03-05 15:22:30 -060033 ./fail2ban-2to3
Brad Bishopa48c0142020-01-06 09:48:41 -050034}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append () {
Patrick Williams53961c22022-01-20 11:06:23 -060037 rm -f ${D}/${bindir}/fail2ban-python
Andrew Geissler1fe918a2020-05-15 14:16:47 -050038 install -d ${D}/${sysconfdir}/fail2ban
39 install -d ${D}/${sysconfdir}/init.d
40 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
41 chown -R root:root ${D}/${bindir}
Patrick Williams53961c22022-01-20 11:06:23 -060042 rm -rf ${D}/run
Brad Bishopa48c0142020-01-06 09:48:41 -050043}
44
Patrick Williams213cb262021-08-07 19:21:33 -050045do_install_ptest:append () {
Andrew Geissler1fe918a2020-05-15 14:16:47 -050046 install -d ${D}${PTEST_PATH}
Andrew Geissler9d3cc052021-03-31 13:36:22 -050047 install -d ${D}${PTEST_PATH}/bin
Andrew Geissler1fe918a2020-05-15 14:16:47 -050048 sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest
Andrew Geissler9d3cc052021-03-31 13:36:22 -050049 install -D ${S}/bin/* ${D}${PTEST_PATH}/bin
Patrick Williams53961c22022-01-20 11:06:23 -060050 rm -f ${D}${PTEST_PATH}/bin/fail2ban-python
Brad Bishopa48c0142020-01-06 09:48:41 -050051}
52
Brad Bishopa48c0142020-01-06 09:48:41 -050053
54INITSCRIPT_PACKAGES = "${PN}"
55INITSCRIPT_NAME = "fail2ban-server"
56INITSCRIPT_PARAMS = "defaults 25"
57
Patrick Williams213cb262021-08-07 19:21:33 -050058INSANE_SKIP:${PN}:append = "already-stripped"
Brad Bishopa48c0142020-01-06 09:48:41 -050059
Patrick Williams213cb262021-08-07 19:21:33 -050060RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog} iptables sqlite3 python3-core python3-pyinotify"
61RDEPENDS:${PN} += " python3-logging python3-fcntl python3-json"
62RDEPENDS:${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban"