blob: cbcaac1e97136c41c52c8a9003be1139eb8d9f87 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-or-later"
Brad Bishop15ae2502019-06-18 21:44:24 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050013SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https;branch=main"
14SRCREV = "c3f9f0534e32158f62c43564036878b93b9e0fd6"
Brad Bishop15ae2502019-06-18 21:44:24 -040015
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20# The directory under the ESP that the default bootloader is found in. When
21# wic uses a subdirectory, this should use the same one too.
22EFIDIR ?= "/"
23
24EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
25
26CFLAGS += " -Wno-error"
27
28do_install () {
29 oe_runmake install DESTDIR="${D}"
30}
31
32CLEANBROKEN = "1"
Andrew Geissler595f6302022-01-24 19:11:47 +000033# https://github.com/rhboot/efivar/issues/202
34COMPATIBLE_HOST:libc-musl = 'null'
35