blob: 11d8b9061dbd000e0124d0b8067ff1e3908b9448 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-or-later"
Brad Bishop15ae2502019-06-18 21:44:24 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https;branch=master \
Brad Bishop15ae2502019-06-18 21:44:24 -040014 file://0001-remove-extra-decl.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040015 file://97668ae0bce776a36ea2001dea63d376be8274ac.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000016 file://0001-src-make-compatible-with-efivar-38.patch \
17 "
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
19
20S = "${WORKDIR}/git"
21
22inherit pkgconfig
23
24# The directory under the ESP that the default bootloader is found in. When
25# wic uses a subdirectory, this should use the same one too.
26EFIDIR ?= "/"
27
28EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
29
30CFLAGS += " -Wno-error"
31
32do_install () {
33 oe_runmake install DESTDIR="${D}"
34}
35
36CLEANBROKEN = "1"
Andrew Geissler595f6302022-01-24 19:11:47 +000037# https://github.com/rhboot/efivar/issues/202
38COMPATIBLE_HOST:libc-musl = 'null'
39