blob: b0f4ea6021e121b602f1f333522107b4dff31ddf [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023
24CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
25CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler78b72792022-06-14 06:47:25 -050026SRCREV = "6f88e0f6f1d6eb12c48c902f50f47ecbd3b0f18a"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000027
28SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
29 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030 file://disable_hanging_tests.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050031 file://0001-kvm-Fix-stack-access-mode-in-KVM-test-ELF-headers.patch \
32 file://0002-kvm-use-LD-instead-of-hardcoding-ld.patch \
33 file://0003-Add-KVM_LD-Makefile-variable-for-building-KVM-payloa.patch \
34 file://0001-nfs05_make_tree-Restore-5-min-timeout.patch \
35 file://0001-syscalls-migrate_pages03-restore-runtime-to-5m.patch \
36 file://0001-mountns0-1-3-wait-for-umount-completed-in-thread_b.patch \
37 file://0001-netstress-Restore-runtime-to-5m.patch \
38 file://0001-net_stress-Fix-usage-of-variables-from-tst_net.sh.patch \
39 file://0001-memcg-functional-Fix-usage-of-PAGESIZE-from-memcg_li.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000040 "
41
42S = "${WORKDIR}/git"
43
44inherit autotools-brokensep pkgconfig
45
Andrew Geissler78b72792022-06-14 06:47:25 -050046# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
47# SORT_NONE in linker script which isn't supported by gold:
48# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
49# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
50LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
51
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050052# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
53# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
54# it fails with gold also a bit later when trying to use *-payload.bin
55# http://errors.yoctoproject.org/Errors/Details/663094/
56# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
57KVM_LD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
58
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000059TARGET_CC_ARCH += "${LDFLAGS}"
60
61export prefix = "/opt/${PN}"
62export exec_prefix = "/opt/${PN}"
63
64PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
65EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
66EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
67# ltp network/rpc test cases ftbfs when libtirpc is found
68EXTRA_OECONF += " --without-tirpc "
69
70do_compile() {
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050071 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000072}
73
74do_install(){
75 install -d ${D}${prefix}/
76 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
77
78 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
79 # as it lacks dependency on some perl moudle such as LWP::Simple
80 # And this script previously works as a tool for analyzing failures from LTP
81 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
82 # http://khack.osdl.org to retrieve ltp test results run on
83 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
84 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
85
86 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
87 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
88
89 # Makefile were configured in the build system
90 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
91 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
92 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
93 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
94 -e 's@[^ ]*--sysroot=[^ "]*@@g'
95
96 # The controllers memcg_stree test seems to cause us hangs and takes 900s
97 # (maybe we expect more regular output?), anyhow, skip it
98 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler615f2f12022-07-15 14:00:58 -050099
100 # We don't need to ship the compile logs that open_posix_testsuite writes
101 rm -f ${D}${prefix}/testcases/open_posix_testsuite/logfile.*
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000102}
103
104RDEPENDS:${PN} = "\
105 attr \
106 bash \
107 bc \
108 coreutils \
109 cpio \
110 cronie \
111 curl \
112 e2fsprogs \
113 e2fsprogs-mke2fs \
114 expect \
115 file \
116 gawk \
117 gdb \
118 gzip \
119 iproute2 \
120 ldd \
121 libaio \
122 logrotate \
123 net-tools \
124 perl \
125 python3-core \
126 procps \
127 quota \
128 unzip \
129 util-linux \
130 which \
131 tar \
132"
133
134FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
135
136# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
137INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
138INSANE_SKIP:${PN} += "already-stripped staticdev"
139
140remove_broken_musl_sources() {
141 [ "${TCLIBC}" = "musl" ] || return 0
142
143 cd ${S}
144 echo "WARNING: remove unsupported tests (until they're fixed)"
145
146 # sync with upstream
147 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
148 rm -rfv \
149 testcases/kernel/syscalls/confstr/confstr01.c \
150 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
151 testcases/kernel/syscalls/getcontext/getcontext01.c \
152 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
153 testcases/kernel/syscalls/timer_create/timer_create01.c \
154 testcases/kernel/syscalls/timer_create/timer_create03.c \
155 utils/benchmark/ebizzy-0.3
156}
157do_patch[postfuncs] += "remove_broken_musl_sources"
158
159# Avoid file dependency scans, as LTP checks for things that may or may not
160# exist on the running system. For instance it has specific checks for
161# csh and ksh which are not typically part of OpenEmbedded systems (but
162# can be added via additional layers.)
163SKIP_FILEDEPS:${PN} = '1'