blob: f9d60ff2a9dd0b3f3e2ee7cac7e1154ede4a915a [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00007LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
11 gcr \
12 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
15 libarchive \
16 libdazzle \
17 libhandy \
18 glib-2.0-native \
Patrick Williams03907ee2022-05-01 06:28:52 -050019 coreutils-native \
Andrew Geissler595f6302022-01-24 19:11:47 +000020 "
21
22GNOMEBASEBUILDCLASS = "meson"
23inherit gnomebase gsettings features_check gettext mime-xdg
24REQUIRED_DISTRO_FEATURES = "x11 opengl"
25
26SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
27 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000028 file://migrator.patch \
29 file://distributor.patch \
30 "
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050031SRC_URI[archive.sha256sum] = "7316d3c6500e825d8e57293fa58047c56727bee16cd6b6ac804ffe5d9b229560"
Andrew Geissler595f6302022-01-24 19:11:47 +000032
33PACKAGECONFIG_SOUP ?= "soup2"
34PACKAGECONFIG ??= "${PACKAGECONFIG_SOUP}"
35
36# Developer mode enables debugging
37PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
38PACKAGECONFIG[soup2] = "-Dsoup2=enabled,-Dsoup2=disabled,libsoup-2.4,,,soup3"
39PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
40PACKAGECONFIG[libportal] = "-Dlibportal=enabled,-Dlibportal=disabled,libportal"
41
42FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
43RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"