blob: 8817592d47c2fa75194e64e0ac8d4c57d1619062 [file] [log] [blame]
Brad Bishopdd12ede2019-05-13 14:46:48 -04001FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
Matthew Barth035b6162020-01-14 14:21:46 -06002
3SRC_URI_witherspoon = "file://config.json"
Matthew Barth530e1d82020-11-23 19:40:56 -06004SRC_URI_rainier = "file://rainier-2u/config.json \
5 file://rainier-4u/config.json \
Andrew Geisslerdb94adf2021-03-23 18:54:59 -05006 file://rainier-1s4u/config.json \
Matthew Barth530e1d82020-11-23 19:40:56 -06007 file://everest/config.json \
8 "
Matthew Barth035b6162020-01-14 14:21:46 -06009
10do_install_witherspoon() {
11 install -d ${D}/${datadir}/phosphor-fan-presence/presence/
12 install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
13}
Matthew Barth530e1d82020-11-23 19:40:56 -060014do_install_rainier() {
15 # Install Rainier-2U/4U fan presence config files
16 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
17 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
Andrew Geisslerdb94adf2021-03-23 18:54:59 -050018 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060019 install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
20 install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
Andrew Geisslerdb94adf2021-03-23 18:54:59 -050021 install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060022
23 # Install Everest fan presence config file
24 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
25 install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
26}
Matthew Barth035b6162020-01-14 14:21:46 -060027
28FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
29FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
Matthew Barth530e1d82020-11-23 19:40:56 -060030
31FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
32FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
33FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
Andrew Geisslerdb94adf2021-03-23 18:54:59 -050034FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
Matthew Barth530e1d82020-11-23 19:40:56 -060035FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"