blob: daafae33cbc343a16e789b1e9934dfa7e3d39567 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "TPM2 Access Broker & Resource Manager"
2DESCRIPTION = "This is a system daemon implementing the TPM2 access \
3broker (TAB) & Resource Manager (RM) spec from the TCG. The daemon (tpm2-abrmd) \
4is implemented using Glib and the GObject system. In this documentation and \
5in the code we use `tpm2-abrmd` and `tabrmd` interchangeably. \
6"
7SECTION = "security/tpm"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
11
12DEPENDS = "autoconf-archive dbus glib-2.0 tpm2-tss glib-2.0-native \
13 libtss2 libtss2-mu libtss2-tcti-device libtss2-tcti-mssim"
14
Brad Bishop19323692019-04-05 15:28:33 -040015SRC_URI = "\
Patrick Williams03907ee2022-05-01 06:28:52 -050016 https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz \
Brad Bishop19323692019-04-05 15:28:33 -040017 file://tpm2-abrmd-init.sh \
18 file://tpm2-abrmd.default \
19"
20
Patrick Williams03907ee2022-05-01 06:28:52 -050021SRC_URI[sha256sum] = "a7844a257eaf5176f612fe9620018edc0880cca7036465ad2593f83ae0ad6673"
Brad Bishop19323692019-04-05 15:28:33 -040022
23inherit autotools pkgconfig systemd update-rc.d useradd
24
25SYSTEMD_PACKAGES += "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050026SYSTEMD_SERVICE:${PN} = "tpm2-abrmd.service"
27SYSTEMD_AUTO_ENABLE:${PN} = "disable"
Brad Bishop19323692019-04-05 15:28:33 -040028
29INITSCRIPT_NAME = "${PN}"
30INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 19 0 1 6 ."
31
32USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050033GROUPADD_PARAM:${PN} = "tss"
34USERADD_PARAM:${PN} = "--system -M -d /var/lib/tpm -s /bin/false -g tss tss"
Brad Bishop19323692019-04-05 15:28:33 -040035
36PACKAGECONFIG ?="${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd', '', d)}"
37PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --with-systemdsystemunitdir=no"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040040 install -d "${D}${sysconfdir}/init.d"
41 install -m 0755 "${WORKDIR}/tpm2-abrmd-init.sh" "${D}${sysconfdir}/init.d/tpm2-abrmd"
42
43 install -d "${D}${sysconfdir}/default"
44 install -m 0644 "${WORKDIR}/tpm2-abrmd.default" "${D}${sysconfdir}/default/tpm2-abrmd"
45}
46
Patrick Williams213cb262021-08-07 19:21:33 -050047FILES:${PN} += "${libdir}/systemd/system-preset \
Brad Bishop19323692019-04-05 15:28:33 -040048 ${datadir}/dbus-1"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050RDEPENDS:${PN} += "tpm2-tss"
Brad Bishop19323692019-04-05 15:28:33 -040051
52BBCLASSEXTEND = "native"