blob: efe62a82097fe66e6f00c7e42bf81718a1573150 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL."
2DESCRIPTION = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL for Trusted Platform Module (TPM 2.0) using the tpm2-tss software stack that follows the Trusted Computing Groups (TCG) TPM Software Stack (TSS 2.0). It uses the Enhanced System API (ESAPI) interface of the TSS 2.0 for downwards communication. It supports RSA decryption and signatures as well as ECDSA signatures."
3
Andrew Geissler064f75b2020-06-27 00:14:46 -05004LICENSE = "BSD-3-Clause"
Andrew Geissler9d3cc052021-03-31 13:36:22 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=7b3ab643b9ce041de515d1ed092a36d4"
Brad Bishop19323692019-04-05 15:28:33 -04006
7SECTION = "security/tpm"
8
9DEPENDS = "autoconf-archive-native bash-completion libtss2 libgcrypt openssl"
10
Patrick Williams03907ee2022-05-01 06:28:52 -050011SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/v${PV}/${BPN}-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "ea2941695ac221d23a7f3e1321140e75b1495ae6ade876f2f4c2ed807c65e2a5"
Brad Bishop19323692019-04-05 15:28:33 -040014
15inherit autotools-brokensep pkgconfig systemd
16
Patrick Williams03907ee2022-05-01 06:28:52 -050017# It uses the API deprecated since the OpenSSL 3.0
18CFLAGS:append = ' -Wno-deprecated-declarations -Wno-unused-parameter'
19
20do_configure:prepend() {
21 # do not extract the version number from git
22 sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac
23}
Brad Bishop19323692019-04-05 15:28:33 -040024
25PACKAGES += "${PN}-engines ${PN}-engines-staticdev ${PN}-bash-completion"
26
Patrick Williams03907ee2022-05-01 06:28:52 -050027FILES:${PN}-dev = "${libdir}/engines-3/tpm2tss.so ${includedir}/*"
28FILES:${PN}-engines = "${libdir}/engines-3/lib*.so*"
29FILES:${PN}-engines-staticdev = "${libdir}/engines-3/libtpm2tss.a"
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions"