Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 1 | require go-${PV}.inc |
| 2 | require go-target.inc |
| 3 | |
| 4 | inherit linuxloader |
| 5 | |
| 6 | export GOBUILDMODE="" |
| 7 | export CGO_ENABLED_riscv64 = "" |
| 8 | export GO_LDSO = "${@get_linuxloader(d)}" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 9 | export CC_FOR_TARGET = "gcc" |
| 10 | export CXX_FOR_TARGET = "g++" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 11 | |
| 12 | # mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its |
| 13 | # variants. |
| 14 | python() { |
| 15 | if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True): |
| 16 | d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel") |
| 17 | } |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | |