blob: 8d5a82455b5197e88d1f5ec301823899e792a6db [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "p8platform udev ncurses swig-native python3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Brad Bishopc342db32019-05-15 21:57:59 -040012PV = "4.0.4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Brad Bishopc342db32019-05-15 21:57:59 -040014SRCREV = "3bbd4321618503d14008387a72fabb6743878831"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
Brad Bishope42b3e32020-01-15 22:08:42 -050016 file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
17 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19S = "${WORKDIR}/git"
20
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021inherit cmake pkgconfig
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023# Put client tools into a separate package
24PACKAGE_BEFORE_PN += "${PN}-tools"
25FILES_${PN}-tools = "${bindir}"
Brad Bishop90ca7472019-08-20 09:15:15 -040026RDEPENDS_${PN}-tools = "python3-${BPN} python3-core"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028# Create the wrapper for python3
29PACKAGES += "python3-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
31RDEPENDS_${PN} = "python3-core"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032
33# cec-client and xbmc need the .so present to work :(
34FILES_${PN} += "${libdir}/*.so"
35INSANE_SKIP_${PN} = "dev-so"
36
37# Adapter shows up as a CDC-ACM device
38RRECOMMENDS_${PN} = "kernel-module-cdc-acm"