blob: c61d7c99dcd6c513376cf7ceb1bbb8ac2e7dbcfc [file] [log] [blame]
Brad Bishop0a921262019-09-24 07:40:45 -04001DESCRIPTION = "Utilities to collect and visualise system statistics"
2HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
3
4LICENSE = "GPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9PACKAGES_prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
10
11# don't use the git tag unless docbooc2x is available to build the manpages
12SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92/libstatgrab-0.92.tar.gz \
13 "
14SRC_URI[md5sum] = "5362b2ddbec54b3901e7d70c22cda249"
15SRC_URI[sha256sum] = "5bf1906aff9ffc3eeacf32567270f4d819055d8386d98b9c8c05519012d5a196"
16
17# Perl5 is for tests only
18EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
19
Brad Bishope42b3e32020-01-15 22:08:42 -050020# use with caution - default properties are configured to trace
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[log4cplus] = "--with-log4cplus,--without-log4cplus,log4cplus"
23PACKAGECONFIG[logging] = "--enable-logging,--disable-logging,"
24
Brad Bishop0a921262019-09-24 07:40:45 -040025inherit autotools pkgconfig
26
27FILES_statgrab = "${bindir}/statgrab"
28FILES_statgrab-dbg = "${bindir}/.debug/statgrab"
29FILES_saidar = "${bindir}/saidar"
30FILES_saidar-dbg = "${bindir}/.debug/saidar"
31FILES_${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
32RDEPENDS_${PN}-mrtg_append = "perl statgrab"