blob: 7c6f4c13d2a2ab96db03e9de2f2917c4e88e8c73 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
6 "
7
8SRC_URI = "git://github.com/libyui/libyui.git \
Brad Bishop316dfdd2018-06-25 12:45:53 -04009 file://0001-Fix-build-with-clang.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://0001-Use-relative-install-paths-for-CMake.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040011 "
12
Brad Bishop779d0ac2019-09-27 08:23:48 -040013SRCREV = "8459235919f592b1bc099ecf9a947cb6344b6fa5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014SRCREV_FORMAT = "default"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015S = "${WORKDIR}/git"
16
17inherit cmake gettext pkgconfig
18
19DEPENDS += "boost"
20
Brad Bishope42b3e32020-01-15 22:08:42 -050021EXTRA_OECMAKE += "-DENABLE_WERROR=OFF"
22
Brad Bishop316dfdd2018-06-25 12:45:53 -040023BBCLASSEXTEND = "native nativesdk"
24
25do_configure_prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 (cd ${S} &&
27 ./bootstrap.sh &&
28 cd -)
Brad Bishop316dfdd2018-06-25 12:45:53 -040029}
30
31do_install_append () {
32 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
33 mv ${D}/usr/lib64 ${D}/usr/lib
34 fi
35}
36
37do_install_append_class-nativesdk () {
38 mkdir -p ${D}/${base_prefix}
39 mv ${D}/usr ${D}/${base_prefix}
40}
41
42FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*"