blob: d1fc565085aff6fcb8f303db9afd011a89a8338f [file] [log] [blame]
Patrick Venture6dd5cc92018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
Patrick Venture24d981d2019-06-28 15:34:15 -07005PV = "1.0+git${SRCPV}"
Patrick Venture6dd5cc92018-11-09 18:27:28 -08006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturea9f19bd2019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venturea26ccf52019-05-03 10:35:28 -070017DEPENDS += "pciutils"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080018
Andrew Geissler79ca37b2019-06-19 18:52:19 +000019PACKAGECONFIG ?= "cleanup-delete"
20PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
21
Patrick Venture51c0f092019-05-15 12:19:16 -070022EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
23
Patrick Venture6dd5cc92018-11-09 18:27:28 -080024S = "${WORKDIR}/git"
25SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geissler5be94932019-07-03 18:31:13 +000026SRCREV = "33311b47b3b656cfc16568b4b971730cb79130bc"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080027
28FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
29FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
30FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
31
32BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
Andrew Geissler79ca37b2019-06-19 18:52:19 +000033BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
Patrick Venture3c1a03b2019-05-08 07:43:10 -070034
35do_configure[depends] += "virtual/kernel:do_shared_workdir"