blob: fd302db897af9acd73c7c85ca791327548150062 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "MCE test suite"
5
6DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \
7testing the Linux RAS related features, including CPU/Memory error \
8containment and recovery, ACPI/APEI support etc."
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-2.0-only"
Brad Bishop19323692019-04-05 15:28:33 -040011LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git;branch=master \
Brad Bishop19323692019-04-05 15:28:33 -040014 file://makefile-remove-ldflags.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \
Brad Bishop19323692019-04-05 15:28:33 -040016 "
Patrick Williamse760df82023-05-26 11:10:49 -050017SRCREV = "025014dedca39d2b8a57a82e52286e72e157d73a"
18PV = "20222810+git${SRCPV}"
Brad Bishop19323692019-04-05 15:28:33 -040019
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} = "mcelog mce-inject dialog bash"
Brad Bishop19323692019-04-05 15:28:33 -040021
22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
23
24S ="${WORKDIR}/git"
25
Patrick Williamse760df82023-05-26 11:10:49 -050026EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028do_install:append(){
Brad Bishop19323692019-04-05 15:28:33 -040029 install -d ${D}/opt/mce-test
30 cp -rf ${S}/* ${D}/opt/mce-test/
31}
32
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:${PN} += "/opt"