blob: c8dabc5eade1bf6dea2622fe9c5e1ace179b0878 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "D-Bus wrapper in C++ for dbus"
2HOMEPAGE = "https://dbus-cxx.github.io/"
3BUGTRACKER = "https://github.com/libsigcplusplus/libsigcplusplus/issues"
4SECTION = "base"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
7
8SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
9 file://0001-Include-typeinfo-for-typeid.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050010 file://0001-include-utility-header.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000011"
12SRC_URI:append:libc-musl = "file://fix_build_musl.patch"
13SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
14
15DEPENDS = "\
16 dbus \
17 libsigc++-3 \
18"
19
20RDEPENDS:${PN} = "\
21 dbus \
22 libsigc++-3 \
23"
24
25S = "${WORKDIR}/git"
26
27inherit pkgconfig cmake
28
29OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"