blob: 2199e0389fa235fa90a52ce20af6420af8065319 [file] [log] [blame]
Brad Bishop3077a7f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005inherit obmc-phosphor-license
6
Brad Bishop93fb5352015-09-09 03:59:20 +00007PROVIDES = "${PACKAGES}"
8PACKAGES = " \
Brad Bishopdb32a7c2017-03-01 16:16:06 -05009 ${PN}-bmc-state-mgmt \
10 ${PN}-chassis-state-mgmt \
Brad Bishopa2429372016-09-06 22:44:21 -040011 ${PN}-extras \
12 ${PN}-extrasdev \
Adriana Kobylak6adca3a2017-11-09 10:39:02 -060013 ${PN}-extrasdevtools \
Brad Bishop4824d4c2017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop4f12f722017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
Brad Bishopeca8d7c2018-03-23 13:07:46 -040018 ${PN}-logging \
Brad Bishop4f12f722017-02-01 21:04:14 -050019 ${PN}-sensors \
Gunnar Mills058788a2017-02-15 16:01:45 -060020 ${PN}-software \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050021 ${PN}-host-check-mgmt \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050022 ${PN}-debug-collector \
Deepak Kodihallifeb88672017-05-17 06:42:51 -050023 ${PN}-settings \
Ratan Guptad3c61642017-07-06 21:09:14 +053024 ${PN}-network \
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053025 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000026 "
27
Brad Bishopdb32a7c2017-03-01 16:16:06 -050028SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
29RDEPENDS_${PN}-bmc-state-mgmt = " \
30 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
31 "
32
33SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
34RDEPENDS_${PN}-chassis-state-mgmt = " \
35 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
36 "
37
Brad Bishopa2429372016-09-06 22:44:21 -040038SUMMARY_${PN}-extras = "Extra features"
39RDEPENDS_${PN}-extras = " \
Brad Bishop3077a7f2017-01-12 21:44:51 -050040 phosphor-rest \
Brad Bishop0f547b12017-05-31 14:08:33 -040041 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040042 "
43
Brad Bishopa2429372016-09-06 22:44:21 -040044SUMMARY_${PN}-extrasdev = "Development features"
45RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylaka3e925f2016-06-16 14:46:06 -050046 rest-dbus \
47 "
Brad Bishop4f12f722017-02-01 21:04:14 -050048
Adriana Kobylak6adca3a2017-11-09 10:39:02 -060049SUMMARY_${PN}-extrasdevtools = "Development tools"
50RDEPENDS_${PN}-extrasdevtools = " \
51 "
52
Brad Bishop4824d4c2017-05-01 11:54:34 -040053# Use the fan control package group for applications
54# implementing fan control or system fan policy only.
55# Applications that create inventory or sensors should
56# be added those respective package groups instead.
57SUMMARY_${PN}-fan-control = "Fan control"
58RDEPENDS_${PN}-fan-control = " \
Matt Spinlerc133ec12017-04-19 08:23:50 -050059 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinlerdd7a0802017-05-01 14:29:20 -050060 phosphor-fan-monitor \
Brad Bishop4824d4c2017-05-01 11:54:34 -040061 "
62
Brad Bishopdb32a7c2017-03-01 16:16:06 -050063SUMMARY_${PN}-host-state-mgmt = "Host state management"
64RDEPENDS_${PN}-host-state-mgmt = " \
65 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritzb3b58992017-03-31 12:04:32 -050066 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050067 "
68
Brad Bishop4f12f722017-02-01 21:04:14 -050069SUMMARY_${PN}-inventory = "Inventory applications"
70RDEPENDS_${PN}-inventory = " \
71 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barthacd9fe42017-02-24 13:14:43 -060072 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop4f12f722017-02-01 21:04:14 -050073 "
74
75SUMMARY_${PN}-leds = "LED applications"
76RDEPENDS_${PN}-leds = " \
Brad Bishopaf7d0602017-02-27 11:59:49 -050077 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
78 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandran6a1b0fc2017-04-27 05:29:56 -050079 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop4f12f722017-02-01 21:04:14 -050080 "
81
Brad Bishopeca8d7c2018-03-23 13:07:46 -040082SUMMARY_${PN}-logging = "Logging applications"
83RDEPENDS_${PN}-logging = " \
84 phosphor-logging \
85 "
86
Brad Bishop4f12f722017-02-01 21:04:14 -050087SUMMARY_${PN}-sensors = "Sensor applications"
88RDEPENDS_${PN}-sensors = " \
89 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
90 "
Gunnar Mills058788a2017-02-15 16:01:45 -060091
Brad Bishop8623bbe2018-03-09 00:04:00 -050092# These packages are not required with UBI enabled
93${PN}-software-extras = " \
94 obmc-flash-bmc \
95 obmc-mgr-download \
96 "
97
Eddie Jamesb2b7ff62018-02-09 11:59:18 -060098${PN}-software-extras_df-obmc-ubi-fs = " \
99 phosphor-image-signing \
100 "
Brad Bishop8623bbe2018-03-09 00:04:00 -0500101
Gunnar Mills058788a2017-02-15 16:01:45 -0600102SUMMARY_${PN}-software = "Software applications"
103RDEPENDS_${PN}-software = " \
Deepak Kodihallib74ceea2017-04-13 23:23:42 -0500104 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Millscfe00842017-05-15 15:40:58 -0500105 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geisslera30470f2018-02-09 12:50:57 -0800106 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop8623bbe2018-03-09 00:04:00 -0500107 ${${PN}-software-extras} \
Andrew Geisslera30470f2018-02-09 12:50:57 -0800108 "
109
Jayanth Othayoth9be81b12017-05-08 09:25:05 -0500110SUMMARY_${PN}-debug-collector = "BMC debug collector"
111RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -0500112 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
113 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothf4e66072017-07-29 22:28:44 -0500114 phosphor-debug-collector-dreport \
Marri Devender Raob6e5cb02017-10-11 02:22:46 -0500115 phosphor-debug-collector-scripts \
Vishwanatha Subbannadfd5bf32017-05-12 23:31:55 +0530116 "
Deepak Kodihallifeb88672017-05-17 06:42:51 -0500117
118SUMMARY_${PN}-settings = "Settings applications"
119RDEPENDS_${PN}-settings = " \
Andrew Geisslera36894f2018-02-05 12:02:35 -0800120 ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \
Deepak Kodihallifeb88672017-05-17 06:42:51 -0500121 "
Ratan Guptad3c61642017-07-06 21:09:14 +0530122
123SUMMARY_${PN}-network = "BMC Network Manager"
124RDEPENDS_${PN}-network = " \
125 ${VIRTUAL-RUNTIME_obmc-network-manager} \
126 "
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +0530127
128SUMMARY_${PN}-user-mgmt = "User management applications"
129RDEPENDS_${PN}-user-mgmt = " \
130 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
131 "