blob: 2fc69ca9035eaeb663415d573cedff320cc4172d [file] [log] [blame]
James Feist9ed709c2018-10-02 16:45:42 -07001SUMMARY = "Entity Manager"
2DESCRIPTION = "Entity Manager provides d-bus configuration data \
3and configures system sensors"
4
Brad Bishopf55c8752020-08-18 19:06:53 -04005SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
Andrew Geissler9e498222020-11-05 20:01:08 +00006SRCREV = "c61ae35c3aa09960d816a8acc4f931274ac104db"
James Feist9ed709c2018-10-02 16:45:42 -07007PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
11
James Feist9ed709c2018-10-02 16:45:42 -070012DEPENDS = "boost \
Brad Bishoped869752020-11-06 09:39:44 -050013 dbus \
James Feist9ed709c2018-10-02 16:45:42 -070014 nlohmann-json \
15 sdbusplus \
16 valijson"
17
Brad Bishopd8b59672020-10-27 09:22:51 -040018S = "${WORKDIR}/git"
Brad Bishop76356112020-02-14 14:07:11 -050019inherit meson systemd
Brad Bishop6d17b7b2020-03-18 16:33:02 -040020
Brad Bishopc83dff02020-03-30 14:16:34 -040021EXTRA_OEMESON = "-Dtests=disabled"
22
Brad Bishopc1371fd2020-08-18 19:30:11 -040023PACKAGECONFIG ??= "ipmi-fru"
Brad Bishop6d17b7b2020-03-18 16:33:02 -040024PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
Brad Bishopf55c8752020-08-18 19:06:53 -040025
Brad Bishopc1371fd2020-08-18 19:30:11 -040026EXTRA_ENTITY_MANAGER_PACKAGES = " \
27 ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
28 "
29
30PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
31
Brad Bishopf55c8752020-08-18 19:06:53 -040032do_install_append() {
33 install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
34}
Brad Bishopc1371fd2020-08-18 19:30:11 -040035
Brad Bishoped869752020-11-06 09:39:44 -050036FILES_${PN} += " \
37 ${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \
38 "
Brad Bishopc1371fd2020-08-18 19:30:11 -040039FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
40
41SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
42SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service"
43SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service"
44SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable"