blob: aa54b4a08c352dfa910f009a897aec5507eb017f [file] [log] [blame]
Brad Bishop96ff1982019-08-19 13:50:42 -04001inherit goarch
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002
Brad Bishop316dfdd2018-06-25 12:45:53 -04003GO_PARALLEL_BUILD ?= "${@oe.utils.parallel_make_argument(d, '-p %d')}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
Patrick Williams213cb262021-08-07 19:21:33 -05005GOROOT:class-native = "${STAGING_LIBDIR_NATIVE}/go"
6GOROOT:class-nativesdk = "${STAGING_DIR_TARGET}${libdir}/go"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007GOROOT = "${STAGING_LIBDIR}/go"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008export GOROOT
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009export GOROOT_FINAL = "${libdir}/go"
Brad Bishopc8f47122019-06-24 09:36:18 -040010export GOCACHE = "${B}/.cache"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishopd89cb5f2019-04-10 09:02:41 -040012export GOARCH = "${TARGET_GOARCH}"
13export GOOS = "${TARGET_GOOS}"
14export GOHOSTARCH="${BUILD_GOARCH}"
15export GOHOSTOS="${BUILD_GOOS}"
16
17GOARM[export] = "0"
Patrick Williams213cb262021-08-07 19:21:33 -050018GOARM:arm:class-target = "${TARGET_GOARM}"
19GOARM:arm:class-target[export] = "1"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040020
21GO386[export] = "0"
Patrick Williams213cb262021-08-07 19:21:33 -050022GO386:x86:class-target = "${TARGET_GO386}"
23GO386:x86:class-target[export] = "1"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040024
25GOMIPS[export] = "0"
Patrick Williams213cb262021-08-07 19:21:33 -050026GOMIPS:mips:class-target = "${TARGET_GOMIPS}"
27GOMIPS:mips:class-target[export] = "1"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040028
Patrick Williams213cb262021-08-07 19:21:33 -050029DEPENDS_GOLANG:class-target = "virtual/${TUNE_PKGARCH}-go virtual/${TARGET_PREFIX}go-runtime"
30DEPENDS_GOLANG:class-native = "go-native"
31DEPENDS_GOLANG:class-nativesdk = "virtual/${TARGET_PREFIX}go-crosssdk virtual/${TARGET_PREFIX}go-runtime"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032
Patrick Williams213cb262021-08-07 19:21:33 -050033DEPENDS:append = " ${DEPENDS_GOLANG}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
35GO_LINKSHARED ?= "${@'-linkshared' if d.getVar('GO_DYNLINK') else ''}"
36GO_RPATH_LINK = "${@'-Wl,-rpath-link=${STAGING_DIR_TARGET}${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
37GO_RPATH = "${@'-r ${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
Patrick Williams213cb262021-08-07 19:21:33 -050038GO_RPATH:class-native = "${@'-r ${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
39GO_RPATH_LINK:class-native = "${@'-Wl,-rpath-link=${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040GO_EXTLDFLAGS ?= "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${GO_RPATH_LINK} ${LDFLAGS}"
41GO_LINKMODE ?= ""
Patrick Williams213cb262021-08-07 19:21:33 -050042GO_LINKMODE:class-nativesdk = "--linkmode=external"
43GO_LINKMODE:class-native = "--linkmode=external"
Andrew Geisslereff27472021-10-29 15:35:00 -050044GO_EXTRA_LDFLAGS ?= ""
45GO_LDFLAGS ?= '-ldflags="${GO_RPATH} ${GO_LINKMODE} ${GO_EXTRA_LDFLAGS} -extldflags '${GO_EXTLDFLAGS}'"'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050046export GOBUILDFLAGS ?= "-v ${GO_LDFLAGS} -trimpath"
Brad Bishop316dfdd2018-06-25 12:45:53 -040047export GOPATH_OMIT_IN_ACTIONID ?= "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048export GOPTESTBUILDFLAGS ?= "${GOBUILDFLAGS} -c"
Brad Bishop316dfdd2018-06-25 12:45:53 -040049export GOPTESTFLAGS ?= ""
Patrick Williams213cb262021-08-07 19:21:33 -050050GOBUILDFLAGS:prepend:task-compile = "${GO_PARALLEL_BUILD} "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051
52export GO = "${HOST_PREFIX}go"
53GOTOOLDIR = "${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go/pkg/tool/${BUILD_GOTUPLE}"
Patrick Williams213cb262021-08-07 19:21:33 -050054GOTOOLDIR:class-native = "${STAGING_LIBDIR_NATIVE}/go/pkg/tool/${BUILD_GOTUPLE}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055export GOTOOLDIR
56
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057export CGO_ENABLED ?= "1"
58export CGO_CFLAGS ?= "${CFLAGS}"
59export CGO_CPPFLAGS ?= "${CPPFLAGS}"
60export CGO_CXXFLAGS ?= "${CXXFLAGS}"
61export CGO_LDFLAGS ?= "${LDFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050062
63GO_INSTALL ?= "${GO_IMPORT}/..."
Brad Bishopd7bf8c12018-02-25 22:55:05 -050064GO_INSTALL_FILTEROUT ?= "${GO_IMPORT}/vendor/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050065
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066B = "${WORKDIR}/build"
67export GOPATH = "${B}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040068export GOTMPDIR ?= "${WORKDIR}/go-tmp"
69GOTMPDIR[vardepvalue] = ""
Brad Bishopd7bf8c12018-02-25 22:55:05 -050070
71python go_do_unpack() {
72 src_uri = (d.getVar('SRC_URI') or "").split()
73 if len(src_uri) == 0:
74 return
75
Brad Bishop08902b02019-08-20 09:16:51 -040076 fetcher = bb.fetch2.Fetch(src_uri, d)
77 for url in fetcher.urls:
78 if fetcher.ud[url].type == 'git':
79 if fetcher.ud[url].parm.get('destsuffix') is None:
80 s_dirname = os.path.basename(d.getVar('S'))
81 fetcher.ud[url].parm['destsuffix'] = os.path.join(s_dirname, 'src', d.getVar('GO_IMPORT')) + '/'
82 fetcher.unpack(d.getVar('WORKDIR'))
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083}
84
85go_list_packages() {
86 ${GO} list -f '{{.ImportPath}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \
87 egrep -v '${GO_INSTALL_FILTEROUT}'
88}
89
90go_list_package_tests() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040091 ${GO} list -f '{{.ImportPath}} {{.TestGoFiles}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050092 grep -v '\[\]$' | \
93 egrep -v '${GO_INSTALL_FILTEROUT}' | \
94 awk '{ print $1 }'
95}
96
97go_do_configure() {
98 ln -snf ${S}/src ${B}/
99}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400100do_configure[dirs] =+ "${GOTMPDIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500101
102go_do_compile() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400103 export TMPDIR="${GOTMPDIR}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500104 if [ -n "${GO_INSTALL}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400105 if [ -n "${GO_LINKSHARED}" ]; then
106 ${GO} install ${GOBUILDFLAGS} `go_list_packages`
107 rm -rf ${B}/bin
108 fi
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500109 ${GO} install ${GO_LINKSHARED} ${GOBUILDFLAGS} `go_list_packages`
110 fi
111}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400112do_compile[dirs] =+ "${GOTMPDIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500113do_compile[cleandirs] = "${B}/bin ${B}/pkg"
114
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500115go_do_install() {
116 install -d ${D}${libdir}/go/src/${GO_IMPORT}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400117 tar -C ${S}/src/${GO_IMPORT} -cf - --exclude-vcs --exclude '*.test' --exclude 'testdata' . | \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500118 tar -C ${D}${libdir}/go/src/${GO_IMPORT} --no-same-owner -xf -
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600119 tar -C ${B} -cf - --exclude-vcs --exclude '*.test' --exclude 'testdata' pkg | \
120 tar -C ${D}${libdir}/go --no-same-owner -xf -
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500121
122 if [ -n "`ls ${B}/${GO_BUILD_BINDIR}/`" ]; then
123 install -d ${D}${bindir}
124 install -m 0755 ${B}/${GO_BUILD_BINDIR}/* ${D}${bindir}/
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500125 fi
126}
127
Brad Bishop316dfdd2018-06-25 12:45:53 -0400128go_stage_testdata() {
129 oldwd="$PWD"
130 cd ${S}/src
131 find ${GO_IMPORT} -depth -type d -name testdata | while read d; do
132 if echo "$d" | grep -q '/vendor/'; then
133 continue
134 fi
135 parent=`dirname $d`
136 install -d ${D}${PTEST_PATH}/$parent
137 cp --preserve=mode,timestamps -R $d ${D}${PTEST_PATH}/$parent/
138 done
139 cd "$oldwd"
140}
141
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500142EXPORT_FUNCTIONS do_unpack do_configure do_compile do_install
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500143
Patrick Williams213cb262021-08-07 19:21:33 -0500144FILES:${PN}-dev = "${libdir}/go/src"
145FILES:${PN}-staticdev = "${libdir}/go/pkg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500146
Patrick Williams213cb262021-08-07 19:21:33 -0500147INSANE_SKIP:${PN} += "ldflags"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800148
149# Add -buildmode=pie to GOBUILDFLAGS to satisfy "textrel" QA checking, but mips
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600150# doesn't support -buildmode=pie, so skip the QA checking for mips/rv32 and its
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800151# variants.
152python() {
Andrew Geissler90fd73c2021-03-05 15:25:55 -0600153 if 'mips' in d.getVar('TARGET_ARCH') or 'riscv32' in d.getVar('TARGET_ARCH'):
Patrick Williams213cb262021-08-07 19:21:33 -0500154 d.appendVar('INSANE_SKIP:%s' % d.getVar('PN'), " textrel")
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800155 else:
156 d.appendVar('GOBUILDFLAGS', ' -buildmode=pie')
157}