blob: 34dc89bb0cc99afeeb6f635048bc8537344d6932 [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
Andrew Geisslerc9f78652020-09-18 14:11:35 -05007export GO_LDSO = "${@get_linuxloader(d)}"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06008export CC_FOR_TARGET = "gcc"
9export CXX_FOR_TARGET = "g++"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050010
Andrew Geissler90fd73c2021-03-05 15:25:55 -060011# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
Andrew Geisslerc9f78652020-09-18 14:11:35 -050012# variants.
13python() {
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
Patrick Williams213cb262021-08-07 19:21:33 -050015 d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel")
Andrew Geisslerc9f78652020-09-18 14:11:35 -050016}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017