blob: 39b87ec82904f719e38a0bf469e696f2579566c7 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Helper tool used when compiling"
2DESCRIPTION = "pkg-config is a helper tool used when compiling applications and libraries. It helps determined \
3the correct compiler/link options. It is also language-agnostic."
4HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
5BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=pkg-config"
6SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
Andrew Geisslereff27472021-10-29 15:35:00 -050011SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012PV = "0.29.2+git${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014SRC_URI = "git://gitlab.freedesktop.org/pkg-config/pkg-config.git;branch=master;protocol=https \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 file://pkg-config-esdk.in \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016 file://pkg-config-native.in \
17 file://fix-glib-configure-libtool-usage.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050019 file://0001-autotools-remove-support-for-the-__int64-type.-See-1.patch \
20 file://0001-autotools-use-C99-printf-format-specifiers-on-Window.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050022
23S = "${WORKDIR}/git"
24
25inherit autotools
26
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# Because of a faulty test, the current auto mode always evaluates to no,
28# so just continue that behaviour.
29#
30EXTRA_OECONF += "--disable-indirect-deps"
31
32PACKAGECONFIG ??= "glib"
Patrick Williams213cb262021-08-07 19:21:33 -050033PACKAGECONFIG:class-native = ""
34PACKAGECONFIG:class-nativesdk = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035
36PACKAGECONFIG[glib] = "--without-internal-glib,--with-internal-glib,glib-2.0 pkgconfig-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050037
38acpaths = "-I ."
39
40BBCLASSEXTEND = "native nativesdk"
41
42# Set an empty dev package to ensure the base PN package gets
43# the pkg.m4 macros, pkgconfig does not deliver any other -dev
44# files.
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:${PN}-dev = ""
46FILES:${PN} += "${datadir}/aclocal/pkg.m4"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050047
48# When using the RPM generated automatic package dependencies, some packages
49# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by
50# specifying an appropriate provide.
Patrick Williams213cb262021-08-07 19:21:33 -050051RPROVIDES:${PN} += "pkgconfig(pkg-config)"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050052
53# Install a pkg-config-native wrapper that will use the native sysroot instead
54# of the MACHINE sysroot, for using pkg-config when building native tools.
Patrick Williams213cb262021-08-07 19:21:33 -050055do_install:append:class-native () {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050056 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
57 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
58 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native
59 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native
Brad Bishopd7bf8c12018-02-25 22:55:05 -050060 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
61 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
62 < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk
63 install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050064}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065
66pkgconfig_sstate_fixup_esdk () {
67 if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then
68 pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}"
69 mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real
70 lnr $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
71 sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native
72 fi
73}
74
Patrick Williams213cb262021-08-07 19:21:33 -050075SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconfig_sstate_fixup_esdk"