blob: f0b7fc81f74ee0c4ec91d2102def1bcb1c6e5cb5 [file] [log] [blame]
Brad Bishopb1e88402017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
Patrick Venturebc174e62018-10-01 20:22:40 -07004PV = "1.0+git${SRCPV}"
Brad Bishopb1e88402017-01-11 11:12:32 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Anton D. Kachalov22e00252021-02-06 12:23:10 +01008inherit meson
Patrick Venturebc174e62018-10-01 20:22:40 -07009inherit obmc-phosphor-systemd
Brad Bishop4186efb2017-01-11 15:30:07 -050010
Matthew Barth3afbeed2020-11-17 08:45:59 -060011PACKAGECONFIG ??= ""
Anton D. Kachalov22e00252021-02-06 12:23:10 +010012# Meson configure option to enable/disable max31785-msl
Matt Spinlerc15c7532021-04-14 14:52:53 -050013PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl=false"
Matthew Barth3afbeed2020-11-17 08:45:59 -060014
Brad Bishop4ce57192017-08-01 21:33:30 -040015PACKAGE_BEFORE_PN = "max31785-msl"
16SYSTEMD_PACKAGES = "${PN} max31785-msl"
17
Brad Bishop4186efb2017-01-11 15:30:07 -050018SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Matthew Barth3afbeed2020-11-17 08:45:59 -060019SYSTEMD_SERVICE_max31785-msl = "${@bb.utils.contains('PACKAGECONFIG', 'max31785-msl', 'phosphor-max31785-msl@.service', '', d)}"
Brad Bishopb1e88402017-01-11 11:12:32 -050020
Brad Bishop6d105112017-02-20 14:36:31 -050021DEPENDS += " \
22 sdbusplus \
William A. Kennington III4e10c562018-10-18 19:23:49 -070023 sdeventplus \
Patrick Venture6e2600f2020-05-21 08:32:30 -070024 stdplus \
Brad Bishop6d105112017-02-20 14:36:31 -050025 phosphor-dbus-interfaces \
26 phosphor-logging \
Patrick Venturef67ce692018-09-14 09:54:18 -070027 gpioplus \
Patrick Venture806405f2019-03-11 14:06:11 -070028 cli11 \
Brad Bishop6d105112017-02-20 14:36:31 -050029 "
30
Anton D. Kachalov22e00252021-02-06 12:23:10 +010031FILES_${PN} += "${base_libdir}/systemd/system/xyz.openbmc_project.Hwmon@.service"
Brad Bishopb1e88402017-01-11 11:12:32 -050032RDEPENDS_${PN} += "\
Joel Stanley1c7e17d2017-09-05 17:44:33 +100033 bash \
Brad Bishopb1e88402017-01-11 11:12:32 -050034 "
35
Brad Bishop3217b272017-02-22 20:50:13 -050036RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
37
Anton D. Kachalov22e00252021-02-06 12:23:10 +010038FILES_max31785-msl = "\
39 ${base_libdir}/systemd/system/phosphor-max31785-msl@.service \
40 ${bindir}/max31785-msl \
41 "
Andrew Geisslerdb32d492021-04-14 13:31:40 +000042RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools bash"
Brad Bishop4ce57192017-08-01 21:33:30 -040043
Brad Bishopb1e88402017-01-11 11:12:32 -050044SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
45
Andrew Geissler78970272021-05-06 22:11:07 +000046SRCREV = "5b520cf494ad65be2d336f60ee622efc456c2e3f"
Brad Bishopb1e88402017-01-11 11:12:32 -050047
48S = "${WORKDIR}/git"