Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "High-level GnuPG encryption/signing API" |
| 2 | DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management" |
| 3 | HOMEPAGE = "http://www.gnupg.org/gpgme.html" |
| 4 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 5 | |
| 6 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 9 | file://src/gpgme.h.in;endline=23;md5=2f0bf06d1c7dcb28532a9d0f94a7ca1d \ |
| 10 | file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 13 | SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \ |
| 14 | file://0001-Revert-build-Make-gpgme.m4-use-gpgrt-config-with-.pc.patch \ |
| 15 | file://0001-pkgconfig.patch \ |
| 16 | file://0002-gpgme-lang-python-gpg-error-config-should-not-be-use.patch \ |
| 17 | file://0003-Correctly-install-python-modules.patch \ |
| 18 | file://0004-python-import.patch \ |
| 19 | file://0005-gpgme-config-skip-all-lib-or-usr-lib-directories-in-.patch \ |
| 20 | file://0006-fix-build-path-issue.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 21 | file://0008-do-not-auto-check-var-PYTHON.patch \ |
| 22 | file://0001-use-closefrom-on-linux-and-glibc-2.34.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | file://0001-posix-io.c-Use-off_t-instead-of-off64_t.patch \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 24 | file://0001-autogen.sh-remove-unknown-in-version.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 25 | " |
| 26 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 27 | SRC_URI[sha256sum] = "9551e37081ad3bde81018a0d24f245c3f8206990549598fb31a97a68380a7b71" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 28 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 29 | PYTHON_DEPS = "${@bb.utils.contains('LANGUAGES', 'python', 'swig-native', '', d)}" |
| 30 | |
| 31 | DEPENDS = "libgpg-error libassuan ${PYTHON_DEPS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 32 | RDEPENDS:${PN}-cpp += "libstdc++" |
| 33 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 34 | RDEPENDS:python3-gpg += "python3-unixadmin" |
| 35 | |
| 36 | BINCONFIG = "${bindir}/gpgme-config" |
| 37 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 38 | # Default in configure.ac: "cl cpp python qt" |
| 39 | # Supported: "cl cpp python python2 python3 qt" |
| 40 | # python says 'search and find python2 or python3' |
| 41 | |
| 42 | # Building the C++ bindings for native requires a C++ compiler with C++11 |
| 43 | # support. Since these bindings are currently not needed, we can disable them. |
| 44 | DEFAULT_LANGUAGES = "" |
| 45 | DEFAULT_LANGUAGES:class-target = "cpp" |
| 46 | LANGUAGES ?= "${DEFAULT_LANGUAGES} python" |
| 47 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 48 | PYTHON_INHERIT = "${@bb.utils.contains('LANGUAGES', 'python', 'setuptools3-base', '', d)}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 49 | |
| 50 | EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \ |
| 51 | --disable-gpgconf-test \ |
| 52 | --disable-gpg-test \ |
| 53 | --disable-gpgsm-test \ |
| 54 | --disable-g13-test \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 55 | ' |
| 56 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 57 | inherit autotools texinfo binconfig-disabled pkgconfig ${PYTHON_INHERIT} python3native multilib_header |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 58 | |
| 59 | export PKG_CONFIG='pkg-config' |
| 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |
| 62 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 63 | PACKAGES =+ "${PN}-cpp python3-gpg" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 64 | |
| 65 | FILES:${PN}-cpp = "${libdir}/libgpgmepp.so.*" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 66 | FILES:python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 67 | FILES:${PN}-dev += "${datadir}/common-lisp/source/gpgme/*" |
| 68 | |
| 69 | CFLAGS:append:libc-musl = " -D__error_t_defined " |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 70 | CACHED_CONFIGUREVARS:libc-musl = "ac_cv_sys_file_offset_bits=no" |
| 71 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 72 | do_configure:prepend () { |
| 73 | # Else these could be used in preference to those in aclocal-copy |
| 74 | rm -f ${S}/m4/gpg-error.m4 |
| 75 | rm -f ${S}/m4/libassuan.m4 |
| 76 | rm -f ${S}/m4/python.m4 |
| 77 | } |
| 78 | |
| 79 | do_install:append() { |
| 80 | oe_multilib_header gpgme.h |
| 81 | } |