blob: 3a5ecbcc2d53b4ec869edae6738be6d7cfcea29e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Userspace RCU (read-copy-update) library"
2HOMEPAGE = "http://lttng.org/urcu"
3BUGTRACKER = "http://lttng.org/project/issues"
4
5LICENSE = "LGPLv2.1+ & MIT-style"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
7 file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
8 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
9
10SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
11
Andrew Geissler4ed12e12020-06-05 18:00:41 -050012SRC_URI[md5sum] = "5e419d7b30d0d98bffe0014c704ae936"
13SRC_URI[sha256sum] = "bbfaead0345642b97e0de90f889dfbab4b2643a6a5e5c6bb59cd0d26fc0bcd0e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/userspace-rcu-${PV}"
16inherit autotools multilib_header
17
18CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"
19
20do_install_append() {
21 oe_multilib_header urcu/config.h
22}