blob: 35bb5650b3b3fa510cac65de9d98ef7cee6ed838 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04008LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04009LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
Brad Bishopf3f93bb2019-10-16 14:33:32 -040015SRC_URI[md5sum] = "21af603d9a591c7d96a6457021d84e6c"
16SRC_URI[sha256sum] = "635237637c5b619bcceba91900666b64d56ecb7be63f298f601ec786ce087094"
Brad Bishop19323692019-04-05 15:28:33 -040017
Brad Bishop96ff1982019-08-19 13:50:42 -040018inherit autotools binconfig-disabled pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040019
20BINCONFIG = "${bindir}/pcap-config"
21
22# Explicitly disable dag support. We don't have recipe for it and if enabled here,
23# configure script poisons the include dirs with /usr/local/include even when the
24# support hasn't been detected.
25EXTRA_OECONF = " \
26 --with-pcap=linux \
27 --without-dag \
28 "
29EXTRA_AUTORECONF += "--exclude=aclocal"
30
Brad Bishop96ff1982019-08-19 13:50:42 -040031PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
Brad Bishop19323692019-04-05 15:28:33 -040032 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
33"
34PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
35PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
38
39do_configure_prepend () {
40 #remove hardcoded references to /usr/include
41 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
42}
43
44BBCLASSEXTEND = "native"