blob: 831a91be6588a08cf5de54c2f3c44c6407134d65 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001SUMMARY = "A commandline OMX player for the Raspberry Pi"
2DESCRIPTION = "This player was developed as a testbed for the XBMC \
3Raspberry PI implementation and is quite handy to use standalone"
4HOMEPAGE = "https://github.com/popcornmix/omxplayer"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native userland"
11
Patrick Williams8b8bc412016-08-17 15:02:23 -050012PR = "r4"
13
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014SRCREV_default = "b4bbef8fac5e8c2ddafa895f98456ba715b39c6b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16# omxplayer builds its own copy of ffmpeg from source instead of using the
17# system's ffmpeg library. This isn't ideal but it's ok for now. We do however
18# want to keep control of the exact version of ffmpeg used instead of just
19# fetching the latest commit on a release branch (which is what the checkout job
20# in Makefile.ffmpeg in the omxplayer source tree does).
21#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# This SRCREV corresponds to the v4.0.3 release of ffmpeg.
23SRCREV_ffmpeg = "fcbd117df3077bad495e99e20f01cf93737bce76"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
Patrick Williams8b8bc412016-08-17 15:02:23 -050025SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 git://github.com/FFmpeg/FFmpeg;branch=release/4.0;protocol=git;depth=1;name=ffmpeg;destsuffix=git/ffmpeg \
Patrick Williams8b8bc412016-08-17 15:02:23 -050027 file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
28 file://0003-Remove-strip-step-in-Makefile.patch \
29 file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \
30 file://fix-tar-command-with-DIST.patch \
31 file://use-native-pkg-config.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 file://0005-Don-t-require-internet-connection-during-build.patch \
33 file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 file://0001-Specify-cc-cxx-and-ld-variables-from-environment.patch \
35 file://cross-crompile-ffmpeg.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040036 file://0007-Remove-Makefile-hardcoded-arch-tune.patch \
Patrick Williams8b8bc412016-08-17 15:02:23 -050037 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
39SRC_URI_append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}"
40
Patrick Williams8b8bc412016-08-17 15:02:23 -050041S = "${WORKDIR}/git"
42
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043COMPATIBLE_MACHINE = "^rpi$"
44
45def cpu(d):
46 for arg in (d.getVar('TUNE_CCARGS') or '').split():
47 if arg.startswith('-mcpu='):
48 return arg[6:]
49 return 'generic'
50
51export CPU = "${@cpu(d)}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050052
53inherit autotools-brokensep pkgconfig
54
Brad Bishop316dfdd2018-06-25 12:45:53 -040055# This isn't used directly by omxplayer, but applied to Makefile.ffmpeg which
56# runs the ffmpeg configuration
57PACKAGECONFIG ??= ""
58PACKAGECONFIG[samba] = "--enable-libsmbclient,--disable-libsmbclient,samba"
59
Patrick Williams8b8bc412016-08-17 15:02:23 -050060# Needed in ffmpeg configure
61export TEMPDIR = "${S}/tmp"
62
63# Needed in Makefile.ffmpeg
64export HOST = "${HOST_SYS}"
65export WORK = "${S}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050066export FFMPEG_EXTRA_CFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
67export FFMPEG_EXTRA_LDFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050068
69# Needed in top Makefile
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080070
Patrick Williams8b8bc412016-08-17 15:02:23 -050071export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
72 -L${STAGING_DIR_HOST}/lib \
73 -L${STAGING_DIR_HOST}/usr/lib \
74 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080075export INCLUDES = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " -D__GBM__", "", d)} \
76 -isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
Patrick Williams8b8bc412016-08-17 15:02:23 -050077 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
78 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
79 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \
80 -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \
81 "
82export DIST = "${D}"
83
84do_compile() {
85 # Needed for compiler test in ffmpeg's configure
86 mkdir -p tmp
87
Brad Bishop316dfdd2018-06-25 12:45:53 -040088 sed -i 's/--enable-libsmbclient/${@bb.utils.contains("PACKAGECONFIG", "samba", "--enable-libsmbclient", "--disable-libsmbclient", d)}/g' Makefile.ffmpeg
89
Brad Bishopd7bf8c12018-02-25 22:55:05 -050090 oe_runmake -f Makefile.ffmpeg
91 oe_runmake -f Makefile.ffmpeg install
Patrick Williams8b8bc412016-08-17 15:02:23 -050092 oe_runmake
93}
94
95do_install() {
96 oe_runmake STRIP='echo skipping strip' dist
97 mkdir -p ${D}${datadir}/fonts/truetype/freefont/
98 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
99}
100
101FILES_${PN} = "${bindir}/omxplayer* \
102 ${libdir}/omxplayer/lib*${SOLIBS} \
103 ${datadir}/fonts"
104
105FILES_${PN}-dev += "${libdir}/omxplayer/*.so"
106
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800107RDEPENDS_${PN} += "bash procps userland"