Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU file archiving program" |
| 2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ |
| 3 | or disk archive, and can restore individual files from the archive." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/tar/" |
| 5 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \ |
| 10 | file://CVE-2022-48303.patch \ |
| 11 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "b44cc67f8a1f6b0250b7c860e952b37e8ed932a90bd9b1862a511079255646ff" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | |
| 15 | inherit autotools gettext texinfo |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
| 20 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 21 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | |
| 23 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 24 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no" |
| 26 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | # Let aclocal use the relative path for the m4 file rather than the |
| 28 | # absolute since tar has a lot of m4 files, otherwise there might |
| 29 | # be an "Argument list too long" error when it is built in a long/deep |
| 30 | # directory. |
| 31 | acpaths = "-I ./m4" |
| 32 | |
| 33 | do_install () { |
| 34 | autotools_do_install |
| 35 | ln -s tar ${D}${bindir}/gtar |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | do_install:append:class-target() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 39 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 40 | install -d ${D}${base_bindir} |
| 41 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar |
| 42 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar |
| 43 | rmdir ${D}${bindir}/ |
| 44 | fi |
| 45 | } |
| 46 | |
| 47 | PACKAGES =+ "${PN}-rmt" |
| 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 50 | |
| 51 | inherit update-alternatives |
| 52 | |
| 53 | ALTERNATIVE_PRIORITY = "100" |
| 54 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 55 | ALTERNATIVE:${PN} = "tar" |
| 56 | ALTERNATIVE:${PN}-rmt = "rmt" |
| 57 | ALTERNATIVE:${PN}:class-nativesdk = "" |
| 58 | ALTERNATIVE:${PN}-rmt:class-nativesdk = "" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 59 | |
| 60 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 61 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 62 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 63 | PROVIDES:append:class-native = " tar-replacement-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 64 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" |
| 65 | |
| 66 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 67 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 68 | # Avoid false positives from CVEs in node-tar package |
| 69 | # For example CVE-2021-{32803,32804,37701,37712,37713} |
| 70 | CVE_PRODUCT = "gnu:tar" |