Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # ppe42-gcc |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Klaus Heinrich Kiwi | 0b9616d | 2019-10-29 18:28:45 -0300 | [diff] [blame] | 7 | PPE42_GCC_VERSION ?= b4772a9fa65ea0dd812f8f305ce157bb1cb5ab4a |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 8 | PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION)) |
| 9 | PPE42_GCC_LICENSE = GPLv3+ |
| 10 | |
William A. Kennington III | b2ef611 | 2017-04-14 15:56:20 -0700 | [diff] [blame] | 11 | PPE42_GCC_DEPENDENCIES = ppe42-binutils gmp mpfr mpc |
| 12 | HOST_PPE42_GCC_DEPENDENCIES = host-ppe42-binutils host-gmp host-mpfr host-mpc |
Klaus Heinrich Kiwi | dc4a86f | 2020-05-11 16:29:14 -0300 | [diff] [blame] | 13 | PPE42_GCC_PROVIDES = ppe42-toolchain |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 14 | |
Klaus Heinrich Kiwi | b64ca28 | 2020-05-12 14:42:44 -0300 | [diff] [blame] | 15 | PPE42_GCC_DIR = $(HOST_DIR)/$(PPE42_TOOLCHAIN_DIR) |
| 16 | PPE42_GCC_BIN = $(HOST_DIR)/$(PPE42_TOOLCHAIN_BIN) |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 17 | |
| 18 | define HOST_PPE42_GCC_BUILD_CMDS |
| 19 | cd $(@D) && \ |
| 20 | ./configure --prefix=$(PPE42_GCC_DIR) \ |
| 21 | --exec-prefix=$(PPE42_GCC_BIN) \ |
Doug Gilbert | 9a438d0 | 2016-10-31 13:43:07 -0500 | [diff] [blame] | 22 | --target=powerpc-eabi \ |
| 23 | --without-headers \ |
| 24 | --with-newlib \ |
| 25 | --with-gnu-as \ |
| 26 | --with-gnu-ld \ |
| 27 | --with-gmp=$(HOST_DIR)/usr \ |
| 28 | --with-mpfr=$(HOST_DIR)/usr \ |
Klaus Heinrich Kiwi | 7965ad6 | 2021-02-04 06:48:10 -0600 | [diff] [blame] | 29 | --with-sysroot=$(STAGING_DIR) \ |
| 30 | --with-build-time-tools=$(PPE42_TOOLCHAIN_BIN)/bin \ |
Doug Gilbert | 9a438d0 | 2016-10-31 13:43:07 -0500 | [diff] [blame] | 31 | && \ |
Stewart Smith | aa697d0 | 2017-02-17 18:49:10 +1100 | [diff] [blame] | 32 | $(MAKE) configure-host && \ |
| 33 | $(MAKE) CFLAGS=-Wno-error all-gcc |
Matt Ploetz | c19ce76 | 2016-09-01 18:18:56 -0500 | [diff] [blame] | 34 | endef |
| 35 | |
| 36 | define HOST_PPE42_GCC_INSTALL_CMDS |
| 37 | bash -c 'cd $(@D) && make install-gcc' |
| 38 | endef |
| 39 | |
| 40 | $(eval $(host-generic-package)) |