blob: f9b302a3dbee7e412ce5a964a8bcb00167dab9ba [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
Brad Bishop19323692019-04-05 15:28:33 -040012DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native libxslt-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
Andrew Geissler1548c072019-02-22 16:03:50 -060015 file://0001-Do-not-set-Wno-unused-but-set-variable.patch \
Brad Bishop19323692019-04-05 15:28:33 -040016 file://0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 "
18
19SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0"
20SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80"
21
22S = "${WORKDIR}/ModemManager-${PV}"
23
Brad Bishop19323692019-04-05 15:28:33 -040024PACKAGECONFIG ??= "mbim qmi \
25 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026"
27
28PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
29PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
30# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
Brad Bishop19323692019-04-05 15:28:33 -040031PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
33PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
34
35EXTRA_OECONF = " \
36 --with-udev-base-dir=${nonarch_base_libdir}/udev \
37"
Andrew Geissler1548c072019-02-22 16:03:50 -060038CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039
40FILES_${PN} += " \
41 ${datadir}/icons \
42 ${datadir}/polkit-1 \
43 ${datadir}/dbus-1 \
44 ${libdir}/ModemManager \
45 ${systemd_unitdir}/system \
46"
47
48FILES_${PN}-dev += " \
49 ${libdir}/ModemManager/*.la \
50"
51
52FILES_${PN}-staticdev += " \
53 ${libdir}/ModemManager/*.a \
54"
55
56FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
57
58SYSTEMD_SERVICE_${PN} = "ModemManager.service"