Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native libxslt-native" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 15 | file://0001-Do-not-set-Wno-unused-but-set-variable.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 16 | file://0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" |
| 20 | SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80" |
| 21 | |
| 22 | S = "${WORKDIR}/ModemManager-${PV}" |
| 23 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 24 | PACKAGECONFIG ??= "mbim qmi \ |
| 25 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 29 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 30 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 31 | PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 33 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 34 | |
| 35 | EXTRA_OECONF = " \ |
| 36 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 37 | " |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 38 | CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | |
| 40 | FILES_${PN} += " \ |
| 41 | ${datadir}/icons \ |
| 42 | ${datadir}/polkit-1 \ |
| 43 | ${datadir}/dbus-1 \ |
| 44 | ${libdir}/ModemManager \ |
| 45 | ${systemd_unitdir}/system \ |
| 46 | " |
| 47 | |
| 48 | FILES_${PN}-dev += " \ |
| 49 | ${libdir}/ModemManager/*.la \ |
| 50 | " |
| 51 | |
| 52 | FILES_${PN}-staticdev += " \ |
| 53 | ${libdir}/ModemManager/*.a \ |
| 54 | " |
| 55 | |
| 56 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 57 | |
| 58 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |