blob: 4c0f2e2e31a589bf26833d6e631c37c43b9ed9ac [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DEPENDS += " \
14 autoconf-archive-native \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 sdbusplus \
18 "
19
20RDEPENDS_${PN} += " \
21 mtd-utils-ubifs \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 sdbusplus \
25 "
26
Adriana Kobylak69d3de02017-05-25 15:48:27 -050027S = "${WORKDIR}"
28SRC_URI += " \
29 file://bios-ubiattach \
30 file://bios-ubiformat"
31
32do_install() {
33 install -d ${D}${sbindir}
34 install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach
35 install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat
36}
37
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050038DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
39SYSTEMD_SERVICE_${PN} += " \
40 obmc-flash-bios-ubiattach.service \
41 obmc-flash-bios-ubimount@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050042 obmc-flash-bios-ubiumount-prsv.service \
43 obmc-flash-bios-ubiumount-rw@.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050044 obmc-flash-bios-squashfsmount@.service \
45 "
46
47SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
Patrick Williams506bc162017-06-01 22:50:02 -050048SRCREV = "5ba6b10e0b3622ceb920a07d1094af7607ae5dff"
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050049
50S = "${WORKDIR}/git"