Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "matplotlib: plotting with Python" |
| 2 | DESCRIPTION = "\ |
| 3 | Matplotlib is a Python 2D plotting library which produces \ |
| 4 | publication-quality figures in a variety of hardcopy formats \ |
| 5 | and interactive environments across platforms." |
| 6 | HOMEPAGE = "https://github.com/matplotlib/matplotlib" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "PSF" |
| 9 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 10 | file://setup.py;beginline=282;endline=282;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ |
| 12 | " |
| 13 | DEPENDS = "\ |
| 14 | freetype \ |
| 15 | libpng \ |
| 16 | python3-numpy-native \ |
| 17 | python3-dateutil-native \ |
| 18 | python3-pytz-native \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 19 | python3-certifi-native \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | " |
| 21 | |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 22 | SRC_URI[sha256sum] = "84d4c4f650f356678a5d658a43ca21a41fca13f9b8b00169c0b76e6a6a948908" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
| 24 | inherit pypi setuptools3 pkgconfig |
| 25 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 26 | # LTO with clang needs lld |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | LDFLAGS:append:toolchain-clang = " -fuse-ld=lld" |
| 28 | LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN} = "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | freetype \ |
| 32 | libpng \ |
| 33 | python3-numpy \ |
| 34 | python3-pyparsing \ |
| 35 | python3-cycler \ |
| 36 | python3-dateutil \ |
| 37 | python3-kiwisolver \ |
| 38 | python3-pytz \ |
| 39 | " |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/setup.cfg" |
| 42 | ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/setup.cfg" |
| 43 | ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/setup.cfg" |
| 44 | do_compile:prepend() { |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 45 | echo [libs] > ${S}/setup.cfg |
| 46 | echo system_freetype = true >> ${S}/setup.cfg |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 47 | ${ENABLELTO} |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 48 | } |
| 49 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | BBCLASSEXTEND = "native" |